Unterformular Herkunftsobjekt sql

18/08/2009 - 13:15 von Wazlav Gizycki | Report spam
Hallo Group,

ich habe ein Unterformular, dass über eine Abfrage beim laden vom
Hauptformular alle Datensàtze nach Datum sortiert anzeigt. Nun habe
ich versucht das Unterformular beim laden über ein SQL String mit
Datensàtzen zu füllen.
Aber das klappt nicht. Ic hhabe ein Ungebundenes Unterformular
eingefügt und dann eine On_Load Prozedur eingefügt.
Ich habe versucht die Daten als QueryDef an das UFO zu übergeben,
klappt aber nicht.

dim qdf as querydef
set qdf = currentdb.querydefs("SelektiereAlle") 'Access
Abfrage die Alle Datensàtze liefert.
qdf.SQL = "select ... "
'SQL aus der Access Abfrage SelektiereAlle mit neuer WHERE Bedingung
...
Me!UFO1.SourceObject = "Abfrage.SelektiereAlle" ' jetzt sollten die
Daten im UFO1 Aktualisiert werden


bekomme auch keine Fehlermeldung, das Untefrormular erscheint
Transparent ohne Daten. Aber die Abfrage selbst liefert mit 'WHERE' 38
Datensàtze.
Irgendwie komme ich da nicht weiter. Hat vielleicht Jemand ein Tipp?
Danke!

Greetz!
 

Lesen sie die antworten

#1 Karl Donaubauer
18/08/2009 - 13:42 | Warnen spam
Wazlav Gizycki wrote:
ich habe ein Unterformular, dass über eine Abfrage beim laden vom
Hauptformular alle Datensàtze nach Datum sortiert anzeigt. Nun habe
ich versucht das Unterformular beim laden über ein SQL String mit
Datensàtzen zu füllen.
Aber das klappt nicht. Ic hhabe ein Ungebundenes Unterformular
eingefügt und dann eine On_Load Prozedur eingefügt.
Ich habe versucht die Daten als QueryDef an das UFO zu übergeben,
klappt aber nicht.

dim qdf as querydef
set qdf = currentdb.querydefs("SelektiereAlle") 'Access
Abfrage die Alle Datensàtze liefert.
qdf.SQL = "select ... "
'SQL aus der Access Abfrage SelektiereAlle mit neuer WHERE Bedingung
...
Me!UFO1.SourceObject = "Abfrage.SelektiereAlle" ' jetzt sollten die
Daten im UFO1 Aktualisiert werden

bekomme auch keine Fehlermeldung, das Untefrormular erscheint
Transparent ohne Daten. Aber die Abfrage selbst liefert mit 'WHERE' 38
Datensàtze.



An sich sollte das funktionieren.

Was meinst du mit "Ungebundenes Unterformular"?
Dass die Eigenschaft "Herkunfstobjekt" des UFo-Steuerelementes
leer ist?

Was meinst du mit "Transparent"?

Und mit "ohne Daten"? Steht dir im UFo ein neuer DS zur Verfügung
oder siehst du nur grauen Hintergrund?

Hast du vielleicht etwas in den Eigenschaften "Verknüpfen von"
und "Verknüpfen nach" des UFo-Steuerelementes stehen und
keine entsprechend verknüpfbaren Daten?

HTH
Karl
********* Ich beantworte keine Access-Fragen per Email. *********
Access-FAQ: http://www.donkarl.com + Anmeldung und Info zur
Access-Entwickler-Konferenz (AEK12), Oktober 2009, Nürnberg

Ähnliche fragen