Upgrade Etch auf Lenny... Problem

06/03/2009 - 19:23 von Frank Burmeister | Report spam
Hallo,

ein Upgrade auf Lenny habe ich wie folgt begonnen:

Erst in sources.list alle Etch auf Lenny umbenannt.

apt-get update && apt-get dist-upgrade

und laufen lassen...

Nach etwas làngerer Zeit:

Fehler traten auf beim Bearbeiten von:
/var/cache/apt/archives/libsigcx-gtk-0.6-1c2_0.6.6-1.1_i386.deb
W: Kann nicht auf die Liste cdrom://[Debian GNU/Linux 4.0 r0 _Lenny_ -
Official i386 NETINST Binary-1 20070407-11:29] lenny/contrib Packages
(/var/
lib/apt/lists/Debian%20GNU_Linux%204.0%20r0%20%5fLenny%5f%20-%20Official%20i386%20NETINST%20Binary-1%2020070407-11:29_dists_lenny_contrib_binary-i3
86_Packages) der Quellpakete zugreifen. - stat (2 Datei oder
Verzeichnis nicht gefunden)
W: Kann nicht auf die Liste cdrom://[Debian GNU/Linux 4.0 r0 _Lenny_ -
Official i386 NETINST Binary-1 20070407-11:29] lenny/main Packages
(/var/lib
/apt/lists/Debian%20GNU_Linux%204.0%20r0%20%5fLenny%5f%20-%20Official%20i386%20NETINST%20Binary-1%2020070407-11:29_dists_lenny_main_binary-i386_Pac
kages) der Quellpakete zugreifen. - stat (2 Datei oder Verzeichnis
nicht gefunden)
W: Probieren Sie „apt-get update“, um diese Probleme zu korrigieren.
E: Sub-process /usr/bin/dpkg returned an error code (1)

Mist. Da hatte ich wohl die ursprüngliche CD-ROM Quelle noch
eingetragen gehabt und den Fehler vorher ignoriert.

Also ausgetragen, ein apt-get update gemacht und dann ein
apt-get dist-upgrade hinterher...

Paketlisten werden gelesen... Fertig
Abhàngigkeitsbaum wird aufgebaut... Fertig
Abhàngigkeiten werden korrigiert... Fertig
Die folgenden zusàtzlichen Pakete werden installiert:
libsigcx-gtk-0.6-1c2
Die folgenden NEUEN Pakete werden installiert:
libsigcx-gtk-0.6-1c2
0 aktualisiert, 1 neu installiert, 0 zu entfernen und 73 nicht
aktualisiert.
1381 nicht vollstàndig installiert oder entfernt.
Es müssen 16,4kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 61,4kB Plattenplatz zusàtzlich benutzt.
Möchten Sie fortfahren [J/n]? J
Hole:1 http://ftp.de.debian.org lenny/main libsigcx-gtk-0.6-1c2
0.6.6-1.1 [16,4kB]
Es wurden 16,4kB in 0s geholt (20,5kB/s)
(Lese Datenbank ... 209624 Dateien und Verzeichnisse sind derzeit
installiert.)
Entpacke libsigcx-gtk-0.6-1c2 (aus
.../libsigcx-gtk-0.6-1c2_0.6.6-1.1_i386.deb) ...
dpkg: Fehler beim Bearbeiten von
/var/cache/apt/archives/libsigcx-gtk-0.6-1c2_0.6.6-1.1_i386.deb (--unpack):
Versuche, »/usr/lib/libsigcx-gtk-0.6.so.1.0.0« zu überschreiben,
welches auch in Paket libsigcx-gtk-0.6-1c2a ist
Fehler traten auf beim Bearbeiten von:
/var/cache/apt/archives/libsigcx-gtk-0.6-1c2_0.6.6-1.1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


Und nun weiss ich nicht weiter.

Was kann ich jetzt tun?

Danke für Hilfe
Frank
 

Lesen sie die antworten

#1 Christian Stubbs
06/03/2009 - 20:48 | Warnen spam
Frank Burmeister writes:

Erst in sources.list alle Etch auf Lenny umbenannt.

apt-get update && apt-get dist-upgrade

und laufen lassen...



Es wird empfohlen, auf aptitude umzusteigen. Auf der Konsole entsprechen
die Parameter in etwa denen von apt-get (aptitude update, aptitude
install, aptitude search etc.).

Dazu am besten erstmal sehen, dass du nen aktuelles Aptitude hast:

apt-get install aptitude oder aptitude install aptitude

Wenn du dann aptitude ohne Parameter startest, kriegst du eine Text-GUI,
auf der du erstmal feststellen kann, ob du irgendwelche Paket-Konflikte
hast.

Zur Bedienung mit "?" in die Hilfe schauen, die wichtigsten Tasten sind
aber "+" und "-" um Pakete hinzuzufügen und zu entfernen.

Vielleicht kannst du das Fehlerhafte Paket erstmal rauswerfen, aber
keine Ahnung ob das wichtig ist. :)

Ähnliche fragen