Upgrade mit großem Versionssprung

05/08/2015 - 18:30 von Sebastian Suchanek | Report spam
Hallo Liste,

Hier[tm] steht noch eine uralte Kiste mit Debian Etch, die ich gerne
zumindest auf Wheezy heben würde - vorzugsweise /ohne/ eine komplette
Neuinstallation. Ja, das ist mutig, ich weiß. :-)

Nach entsprechendem Anpassen von /etc/apt/sources.list und "apt-get
update" làuft "apt-get dist-upgrade" aber leider in einen Fehler:

| The following packages have unmet dependencies:
| multiarch-support: Depends: libc6 (>= 2.13-5) but
| 2.3.6.ds1-13etch10+b1 is installed

Der in http://forums.debian.net/viewtopic.php?f=6&t3957 gefundene Tip
mit "apt-get install multiarch-support libc6" führt nur zu weiteren zu
Abhàngigkeits-Fehlermeldungen:

| The following packages have unmet dependencies:
| libc6: Depends: libc-bin (= 2.13-38+deb7u8) but it is not going to
| be installed
| libc6-dev: Depends: libc6 (= 2.3.6.ds1-13etch10+b1) but
| 2.13-38+deb7u8 is to be installed
| locales: Depends: glibc-2.3.6.ds1-1

Das Spielchen mit "apt-get install" kann ich rekursiv noch etwas weiter
treiben, bis ich schließlich bei

| The following packages have unmet dependencies:
| linux-libc-dev: Conflicts: linux-kernel-headers

An dieser Stelle habe ich dann erstmal abgebrochen, weil ich mir die
Installation nicht zerschießen will. (Da könnte ich ja gleich zur
Komplett-Neuinstallation greifen. ;-))

Lange Rede, kurzer Sinn: Bekommt man das gewünschte Update doch noch
irgendwie hin oder bleibt da doch nur noch der Griff zum Holzhammer?


Tschüs,

Sebastian


Zum AUSTRAGEN schicken Sie eine Mail an debian-user-german-REQUEST@lists.debian.org
mit dem Subject "unsubscribe". Probleme? Mail an listmaster@lists.debian.org (engl)
Archive: https://lists.debian.org/55C23826.70503@gmx.de
 

Lesen sie die antworten

#1 Sebastian Suchanek
05/08/2015 - 18:50 | Warnen spam
Am 05.08.2015 um 18:25 schrieb Stefan Baur:
Am 05.08.2015 um 18:21 schrieb Sebastian Suchanek:
Nach entsprechendem Anpassen von /etc/apt/sources.list und "apt-get
update" làuft "apt-get dist-upgrade" aber leider in einen Fehler:



Niemand weiß, was Du mit "entsprechendem Anpassen" meinst, wenn Du nicht
den Inhalt der sources.list postest.



In der sources.list steht aktuell folgendes:

| deb http://ftp.de.debian.org/debian/ wheezy main non-free
| deb-src http://ftp.de.debian.org/debian/ wheezy main non-free
|
| deb http://security.debian.org/ wheezy/updates main non-free
| deb-src http://security.debian.org/ wheezy/updates main non-free
|
| deb http://ftp.de.debian.org/debian/ wheezy-updates main non-free
| deb-src http://ftp.de.debian.org/debian/ wheezy-updates main non-free

(Copy&Paste von einem anderen Rechner, der IIRC eine
"out-of-the-box"-Neuinstallation von Wheezy hat(te).)

Und Dir ist hoffentlich klar, dass Du von Etch nicht direkt auf Wheezy
kommst, sondern Zwischenschritte für jedes dazwischenliegende Major
Release (also in Deinem Fall konkret Lenny und Squeeze) machen musst?
[...]



Ehrlich gesagt nicht, nein.

Ich versuche daher jetzt erstmal ein Update auf Lenny hinzubekommen...


Tschüs,

Sebastian


Zum AUSTRAGEN schicken Sie eine Mail an
mit dem Subject "unsubscribe". Probleme? Mail an (engl)
Archive: https://lists.debian.org/

Ähnliche fragen