Upgrade oS 12.3 nach 13.1

20/11/2013 - 10:52 von Olaf Meltzer | Report spam
Vor kurzem habe ich drei ziemlich unterschiedlich dimensionierte Rechner
von oS 12.3 auf oS 13.1 heben lassen: Einen Tower (Athlon X2, 4 GB,
Nvidia GT 220, TV-Karte Cinergy DVB-T, oS 64bit), ein Notebook (Intel
Dual Core, 3 GB, Nvidia M9000, oS 32bit) und dieses Nettop (siehe
Signatur).

In allen Fàllen habe ich den passenden Netinstaller des oS 13.1 RC2 von
USB-Stick aus benutzt und ein Update, keine Neuinstallation verlangt.
Schon bei der Konfiguration des Upgrades habe ich die bisher benutzten
Repositories wieder eingebunden -- natürlich nach Anpassung deren URLs
an entsprechende 13.1-Benennung, soweit diese bisher ein 12.3 im Namen
trugen. Mit Ausnahme des Nvidia-Repositories wurden alle, auch die nur
lokal bei mir vorhandenen Repos akzeptiert und auch wàhrend des Upgrades
benutzt.

Im Nachgang dieser Upgrades musste ich bemerkenswert wenig nachbessern.
Wo es hakte (MySQL-Server) lag es an meiner speziellen lokalen
Konfiguration, und ich konnte die schnell wieder einbauen. TV-Karte und
Nvidia-Grafik auf dem Tower funktionierten sofort wieder ohne jegliche
Nacharbeiten. Nvidia-Grafik des Notebook funktionierte erst einmal
nicht. Ich habe deshalb von Nvidias Website das aktuelle Skript zur
Erzeugung der nötigen Kernel-Module besorgt und diese bauen lassen. Der
Grund für diese Komplikation mag gewesen sein, dass ich das Upgrade mit
der Kerneloption nomodeset ausgeführt hatte. Ein erster Versuch ohne
diese hatte zu grafischem Chaos geführt.

KDE-4 auf dem Nettop (nur 1 GB Arbeitsspeicher) startet nun quàlend
langsam. Es war bisher schon etwas zàhflüssig, aber jetzt überlege ich
doch, zukünftig auf dem Nettop etwas schlankeres einzusetzen.

Die KDE-PIM-Suite (Kontact mit Kmail, Knode usw.) möchte ich eigentlich
nicht missen. Aber gerade Kmail ist jetzt fast unertràglich langsam
geworden. Ich fürchte, da muß erst einmal Thunderbird ran.

Insgesamt erscheint mir jedenfalls das Upgrade wenig riskant. Es gibt
ein paar Stellen, wo man evtl. die Geduld verlieren könnte: Gleich zu
Beginn deutet eine grüne Zeile am unteren Bildschirmrand den Verlauf
einiger vorbereitender Maßnahmen an und bleibt möglicherweise làngere
Zeit ohne sichtbaren Fortschritt. Da wàre es angenehmer, tatsàchlich zu
erkennen, mit was der Rechner gerade beschàftigt ist. Das kann man durch
<ESC> erreichen, wodurch vom Bootsplash auf die Textdarstellung
umgeschaltet wird.

Eine weitere Stolperstelle, die ich seit etlichen Jahren immer wieder
erlebe, ist eines der gegen Ende der eigentlichen Installation
ausgeführten Skripte: fetch-ms-ttfonts. Dieses sucht nach einem
möglichst schnell erreichbaren Server, der die Microsoft TrueType Fonts
liefern kann, und làuft bei mir zuverlàssig in ein Timeout. Wenn man an
dieser Stelle "Abbruch" betàtigt, war das ganze bisherige Upgrade für
die Katz. Also "Ignorieren" -- oder bestenfalls "Wiederholen" versuchen.

Gruß -- Olaf Meltzer

openSUSE 13.1 (i586) mit Kernel 3.11.6-4-desktop
KDE: 4.11.2
Nettop mit Intel(R) Atom(TM) CPU 230 2 Core @ 1.60GHz
 

Lesen sie die antworten

#1 Hendrik van Hees
21/11/2013 - 09:59 | Warnen spam
I did a completely new installation, because I don't trust this updating
procedures, and also I like to clean the system with a completely new
installation of a new oS version ;-). For that purpose, I've my /home
and /usr/local on separate partitions of the hard disc and let only / be
formatted for the new installation. The only thing, I had of course to
do by hand to set the appropriate mount points for /home and /usr/local.
Then the installation process run through without any trouble.

I've oS 13.1 on a 64bit Lenovo N 500 and an 32bit eee-pc netbook (also
pretty old). There were no problems whatsoever with both installations.

On 11/20/2013 10:52 AM, Olaf Meltzer wrote:
Vor kurzem habe ich drei ziemlich unterschiedlich dimensionierte Rechner
von oS 12.3 auf oS 13.1 heben lassen: Einen Tower (Athlon X2, 4 GB,
Nvidia GT 220, TV-Karte Cinergy DVB-T, oS 64bit), ein Notebook (Intel
Dual Core, 3 GB, Nvidia M9000, oS 32bit) und dieses Nettop (siehe
Signatur).

In allen Fàllen habe ich den passenden Netinstaller des oS 13.1 RC2 von
USB-Stick aus benutzt und ein Update, keine Neuinstallation verlangt.
Schon bei der Konfiguration des Upgrades habe ich die bisher benutzten
Repositories wieder eingebunden -- natürlich nach Anpassung deren URLs
an entsprechende 13.1-Benennung, soweit diese bisher ein 12.3 im Namen
trugen. Mit Ausnahme des Nvidia-Repositories wurden alle, auch die nur
lokal bei mir vorhandenen Repos akzeptiert und auch wàhrend des Upgrades
benutzt.

Im Nachgang dieser Upgrades musste ich bemerkenswert wenig nachbessern.
Wo es hakte (MySQL-Server) lag es an meiner speziellen lokalen
Konfiguration, und ich konnte die schnell wieder einbauen. TV-Karte und
Nvidia-Grafik auf dem Tower funktionierten sofort wieder ohne jegliche
Nacharbeiten. Nvidia-Grafik des Notebook funktionierte erst einmal
nicht. Ich habe deshalb von Nvidias Website das aktuelle Skript zur
Erzeugung der nötigen Kernel-Module besorgt und diese bauen lassen. Der
Grund für diese Komplikation mag gewesen sein, dass ich das Upgrade mit
der Kerneloption nomodeset ausgeführt hatte. Ein erster Versuch ohne
diese hatte zu grafischem Chaos geführt.

KDE-4 auf dem Nettop (nur 1 GB Arbeitsspeicher) startet nun quàlend
langsam. Es war bisher schon etwas zàhflüssig, aber jetzt überlege ich
doch, zukünftig auf dem Nettop etwas schlankeres einzusetzen.

Die KDE-PIM-Suite (Kontact mit Kmail, Knode usw.) möchte ich eigentlich
nicht missen. Aber gerade Kmail ist jetzt fast unertràglich langsam
geworden. Ich fürchte, da muß erst einmal Thunderbird ran.

Insgesamt erscheint mir jedenfalls das Upgrade wenig riskant. Es gibt
ein paar Stellen, wo man evtl. die Geduld verlieren könnte: Gleich zu
Beginn deutet eine grüne Zeile am unteren Bildschirmrand den Verlauf
einiger vorbereitender Maßnahmen an und bleibt möglicherweise làngere
Zeit ohne sichtbaren Fortschritt. Da wàre es angenehmer, tatsàchlich zu
erkennen, mit was der Rechner gerade beschàftigt ist. Das kann man durch
<ESC> erreichen, wodurch vom Bootsplash auf die Textdarstellung
umgeschaltet wird.

Eine weitere Stolperstelle, die ich seit etlichen Jahren immer wieder
erlebe, ist eines der gegen Ende der eigentlichen Installation
ausgeführten Skripte: fetch-ms-ttfonts. Dieses sucht nach einem
möglichst schnell erreichbaren Server, der die Microsoft TrueType Fonts
liefern kann, und làuft bei mir zuverlàssig in ein Timeout. Wenn man an
dieser Stelle "Abbruch" betàtigt, war das ganze bisherige Upgrade für
die Katz. Also "Ignorieren" -- oder bestenfalls "Wiederholen" versuchen.

Gruß -- Olaf Meltzer





Hendrik van Hees
Frankfurt Institute of Advanced Studies
D-60438 Frankfurt am Main
http://fias.uni-frankfurt.de/~hees/

Ähnliche fragen