.url-Dateien lassen sich ab und zu nicht löschen

18/12/2009 - 12:07 von Michael S | Report spam
Hallo,

ich habe bei zwei identischen Servern ein Problem festgestellt, dass
sporadisch auftritt und das ich bei noch keinem anderen System erlebt habe.
Bisher habe ich die Ursache an der falschen Stelle gesucht, da es den
Anschein hatte es besteht ein Zusammenhang mit einer bestimmten Funktion.
Es gibt doch die zuletzt verwendeten Dokumente, bei denen Windows eine
Verknüpfung in einen speziellen Ordner speichert.
Beide Server fungieren als Domànencontroller und die Benutzer haben
servergespeicherte Profile. Installiert ist Windows 2003 Standard (32 Bit)
mit Exchange. Es handelt sich dabei um eine spezielle Version die man als
Download über einen EDU-Vertrag bekommt (beide Kunden sind Schulen). Ich
meine der Stand des Downloads war R2 SP1.
Das Problem selbst sieht so aus: Irgendwann will Windows eine der
Verknüpfungen aus den zuletzt verwendeten Dateien löschen. Das wird
serverseitig scheinbar auch umgesetzt, nur mit einem großen Fehler: Der
Eintrag in der Verzeichnisstruktur bleibt erhalten! Heisst also, ich kann die
Datei im Explorer noch sehen, allerdings verfügt sie über keinen Reiter
Sicherheit und auch über kein Attribut A (das aber alle anderen Dateien
haben). Löschen ist nicht möglich, ich vermute deshalb weil die Datei selbst
wohl schon nicht mehr existiert.
Ich vermute das, weil die einzig bekannte Lösung ein Neustart des Servers
ist und der Benutzer in dessen Profil die Datei geladen werden soll sich auch
nicht mehr anmelden kann, weil die Datei nicht kopiert werden kann (wohl weil
sie eigentlich nicht mehr da ist). Nach dem Serverneustart ist der Eintrag
weg und der Benutzer kann sich auch wieder anmelden.
Was mich davon abgebracht hat warum die Funktion zuletzt verwendete Dateien
nicht Schuld sein kann ist, dass ich zum einen diese Funktion über die
Gruppenrichtlinien komplett aus dem System entfernt habe (war ein
vorgeschlagener Workaround, wobei mir eine andere Lösung auch lieber wàre).
Und heute ruft einer der beiden Kunden an und sagt das Profil eines
Benutzers geht nicht mehr. Als ich mir das ansehe stelle ich fest, dass eine
Internetverknüpfung aus den Favoriten nicht geladen werden konnte. Der
Benutzer hat gesagt, er hat die Datei gestern gelöscht, und als er sich heute
wieder anmelden wollte kam die Meldung.
Auch hier wurde die Datei immer noch auf dem Server in den Favoriten
angezeigt, allerdings nicht löschbar bis sie nach dem Neustart weg war.
Was sehr interessant an dem Sachverhalt ist, dass die fehlerhaften Dateien
immer Internetverknüpfungen sind. Also auch unter zuletzt verwendete Dateien
sind die fehlerhaften Dateien immer mit der Endung .url.
Es scheint also allgemein ein Problem zu geben, dass url-Dateien im
Benutzerprofil zu Problemen führen können wenn sie gelöscht werden.
Mich verwundert es nur, dass ich das Problem auf keinem anderen System außer
den beiden identischen habe.
Ich habe absolut keine Idee wo ich hier zu suchen anfangen soll.
Die Ereignisanzeige gibt auch keine helfenden Eintràge her.
Beide Server sind Fujitsu TX200S4 mit SAS-Festplatten an einem LSI RAID
Controller mit RAID5.
Ich bin auch schon am überlegen ob der RAID Controller was damit zu tun
haben kann.
Vielen Dank.

Gruß, Michael
 

Lesen sie die antworten

#1 Mario B.
14/01/2010 - 14:07 | Warnen spam
Hallo Michael,
ich habe genau dasselbe Problem, allerdings auf unserem Fileserver. Es
handelt sich auch um einen Windows Server 2003, der bis auf den aktuellen
Stand gepatched ist. Bei mir lassen sich die Dateien auch nach einem Neustart
des Servers nicht löschen. Auch über die Konsole etc. konnte ich die Dateien
nicht löschen / àndern. Ich konnte bis jetzt nur einen neuen Ordner für die
Profile anlegen oder die Servergespeicherten Profile abschalten, was ein sehr
blöder Workaround ist, da das Phànomen nun auch in dem neuen Profilordner
(auf dem selben Server) auftritt. Wir benutzen auf unseren Terminalservern
und den Clients die Software „User Profile Hive Cleanup“, damit sich die
Profile sauber trennen.
Bei uns handelt es sich um einen DL380 G5 von HP. Ich gehe deswegen nicht
davon aus das es sich um ein Hardware Problem handelt, sondern eher um ein
Softwareproblem.

Hast du mittlerweile eine Lösung gefunden?

Gruß, Mario


"Michael S" wrote:

Hallo,

ich habe bei zwei identischen Servern ein Problem festgestellt, dass
sporadisch auftritt und das ich bei noch keinem anderen System erlebt habe.
Bisher habe ich die Ursache an der falschen Stelle gesucht, da es den
Anschein hatte es besteht ein Zusammenhang mit einer bestimmten Funktion.
Es gibt doch die zuletzt verwendeten Dokumente, bei denen Windows eine
Verknüpfung in einen speziellen Ordner speichert.
Beide Server fungieren als Domànencontroller und die Benutzer haben
servergespeicherte Profile. Installiert ist Windows 2003 Standard (32 Bit)
mit Exchange. Es handelt sich dabei um eine spezielle Version die man als
Download über einen EDU-Vertrag bekommt (beide Kunden sind Schulen). Ich
meine der Stand des Downloads war R2 SP1.
Das Problem selbst sieht so aus: Irgendwann will Windows eine der
Verknüpfungen aus den zuletzt verwendeten Dateien löschen. Das wird
serverseitig scheinbar auch umgesetzt, nur mit einem großen Fehler: Der
Eintrag in der Verzeichnisstruktur bleibt erhalten! Heisst also, ich kann die
Datei im Explorer noch sehen, allerdings verfügt sie über keinen Reiter
Sicherheit und auch über kein Attribut A (das aber alle anderen Dateien
haben). Löschen ist nicht möglich, ich vermute deshalb weil die Datei selbst
wohl schon nicht mehr existiert.
Ich vermute das, weil die einzig bekannte Lösung ein Neustart des Servers
ist und der Benutzer in dessen Profil die Datei geladen werden soll sich auch
nicht mehr anmelden kann, weil die Datei nicht kopiert werden kann (wohl weil
sie eigentlich nicht mehr da ist). Nach dem Serverneustart ist der Eintrag
weg und der Benutzer kann sich auch wieder anmelden.
Was mich davon abgebracht hat warum die Funktion zuletzt verwendete Dateien
nicht Schuld sein kann ist, dass ich zum einen diese Funktion über die
Gruppenrichtlinien komplett aus dem System entfernt habe (war ein
vorgeschlagener Workaround, wobei mir eine andere Lösung auch lieber wàre).
Und heute ruft einer der beiden Kunden an und sagt das Profil eines
Benutzers geht nicht mehr. Als ich mir das ansehe stelle ich fest, dass eine
Internetverknüpfung aus den Favoriten nicht geladen werden konnte. Der
Benutzer hat gesagt, er hat die Datei gestern gelöscht, und als er sich heute
wieder anmelden wollte kam die Meldung.
Auch hier wurde die Datei immer noch auf dem Server in den Favoriten
angezeigt, allerdings nicht löschbar bis sie nach dem Neustart weg war.
Was sehr interessant an dem Sachverhalt ist, dass die fehlerhaften Dateien
immer Internetverknüpfungen sind. Also auch unter zuletzt verwendete Dateien
sind die fehlerhaften Dateien immer mit der Endung .url.
Es scheint also allgemein ein Problem zu geben, dass url-Dateien im
Benutzerprofil zu Problemen führen können wenn sie gelöscht werden.
Mich verwundert es nur, dass ich das Problem auf keinem anderen System außer
den beiden identischen habe.
Ich habe absolut keine Idee wo ich hier zu suchen anfangen soll.
Die Ereignisanzeige gibt auch keine helfenden Eintràge her.
Beide Server sind Fujitsu TX200S4 mit SAS-Festplatten an einem LSI RAID
Controller mit RAID5.
Ich bin auch schon am überlegen ob der RAID Controller was damit zu tun
haben kann.
Vielen Dank.

Gruß, Michael

Ähnliche fragen