USB Keyboard in Initrd

08/07/2015 - 14:50 von Alexander Kretschmer | Report spam
Hallo,
ich habe ein System mit raid1, dmcrypt und lvm2.
Es làuft stable / jessie.
Die Platte/das Raid hat eine kleine Partition für Boot, der Rest ist die verschlüsselte Partition, incl. System.

Um das ganze System hochzufahren muss ich also mit einer initrd arbeiten.
Leider bekomme ich meine USB Tastatur nicht zum laufen. Weder in einer Shell, noch für die Passworteingabe zur Entschlüsselung.

Mit dem 3.16.0-4-amd Kernel habe ich es mit Modulen probiert, den neueren 3.16.7 Kernel habe ich nun selbst kompiliert und alle Treiber in den Kernel eingebunden. Es hilft nichts.

In meiner initrd lasse ich mir beim booten per lsmod die geladenen Module anzeigen, per lsusb -t die erkannten USB Geràte. Die Tastatur erscheint in der Auflistung, in der Module-Version meines Kernels wurden auch alle Module ordnungsgemàß geladen, uhci-hcd, ehci-pci, usbhid, alle mit deps.
Die Numlock LED an der Tastatur leuchtet, allerdings làsst sie sich nicht deaktiveren, ebenso reagiert die Tastatur auf nichts anderes - einfach tot.

Ich hab nun schon viel ausprobiert, aber komme einfach nicht weiter. Initrd selbst gebaut, per update-initramfs generieren lassen, keine Wirkung.

Die Internetrecherche bringt mich auch immer wieder zu Seiten, auf denen von Missing Modules die Rede ist, was wohl mal ein Bug war.

Es wàre super, wenn mir hier jemand weiter helfen könnte.

Dank und Gruß
Alex


Zum AUSTRAGEN schicken Sie eine Mail an debian-user-german-REQUEST@lists.debian.org
mit dem Subject "unsubscribe". Probleme? Mail an listmaster@lists.debian.org (engl)
Archive: https://lists.debian.org/559D1A26.5030507@alexkretschmer.de
 

Lesen sie die antworten

#1 Christian Knoke
08/07/2015 - 21:30 | Warnen spam
Alex schrieb am 08. Jul um 14:40 Uhr:
Hallo,
ich habe ein System mit raid1, dmcrypt und lvm2.
Es làuft stable / jessie.

Um das ganze System hochzufahren muss ich also mit einer initrd arbeiten.
Leider bekomme ich meine USB Tastatur nicht zum laufen. Weder in einer
Shell, noch für die Passworteingabe zur Entschlüsselung.

Die Numlock LED an der Tastatur leuchtet, allerdings làsst sie sich nicht
deaktiveren, ebenso reagiert die Tastatur auf nichts anderes - einfach
tot.



USB-Tastatur in initrd làuft problemlos hier, allerdings wheezy. Bei der
Passphrase-Eingabe wird ja nichts angezeigt, Numlock und Capslock sind
gesperrt zum Schutz vor Falscheingabe.

Ich hab nun schon viel ausprobiert, aber komme einfach nicht weiter.



Andere Tastatur? Nicht-Standardbelegung kann Probleme bereiten. Oder, was
ich neulich hatte, Störfeldeinwirkung auf den USB-Hub führte zum Abmelden
von Maus oder Tastatur.

Gruß
Christian

Christian Knoke * * * http://cknoke.de
* * * * * * * * * Ceterum censeo Microsoft esse dividendum.


Zum AUSTRAGEN schicken Sie eine Mail an
mit dem Subject "unsubscribe". Probleme? Mail an (engl)
Archive: https://lists.debian.org/

Ähnliche fragen