User Anwendung unterbricht Datenfluss des System?

13/08/2016 - 21:25 von Andreas Kohlbach | Report spam
Ich habe DSL, lasse Linux selbst PPPOE machen. Das làuft seit
Jahrzehnten problemlos.

Aber wenn ich UT2004 spiele, und den als Server für andere bereit stelle,
*und* jemand eine Map herunter làdt, "erstickt" meine Internet
Verbindung. Das ist reproduzierbar. Und scheinbar genau dann, wenn die
andere Seite den Download der Map gerade beendet hat.

In den Logs von UT2004 finde ich außer

| Debug: Connect Failure

nichts. Leider hat es gar keine Timestamps, dass ich die mit dem Linux
Log synchronisieren könnte.

Linux hat

| Aug 12 18:17:48 ank pppd[3644]: No response to 3 echo-requests
| Aug 12 18:17:48 ank pppd[3644]: Connect time 22.1 minutes.
| Aug 12 18:17:48 ank ppd[3644]: Sent 48831845 bytes, received 10820394 bytes.
| Aug 12 18:17:51 ank pppd[3644]: Connection terminated.
| Aug 12 18:17:51 ank pppoe[20526]: read (asyncReadFromPPP): Session 2657: Input/output error
| Aug 12 18:17:51 ank pppoe[20526]: Sent PADT

Google bringt zu "asyncReadFromPPP" nur alte Eintràge. Und nichts im
Zusammenhang mit anderen Anwendungen, die das verursachen könnten.

Die Anwendung, auch als Server (lauscht auf einem Port größer 1024) làuft
dazu nur mit User Rechten. Wie kann es da die Internet Verbindung zum
Abbruch bringen?
Andreas
You know you're a redneck if
6. You wonder how service stations keep their restrooms so clean.
 

Lesen sie die antworten

#1 Kay Martinen
13/08/2016 - 21:58 | Warnen spam
Am 13.08.2016 um 21:25 schrob Andreas Kohlbach:
Ich habe DSL, lasse Linux selbst PPPOE machen. Das làuft seit
Jahrzehnten problemlos.

Aber wenn ich UT2004 spiele, und den als Server für andere bereit stelle,
*und* jemand eine Map herunter làdt, "erstickt" meine Internet
Verbindung. Das ist reproduzierbar. Und scheinbar genau dann, wenn die
andere Seite den Download der Map gerade beendet hat.

| Aug 12 18:17:48 ank pppd[3644]: No response to 3 echo-requests
| Aug 12 18:17:48 ank ppd[3644]: Sent 48831845 bytes, received 10820394 bytes.



Ca. 48Mbyte gesendet und nur 10Mbyte empfangen. Wie "dick" ist denn dein
Uplink? Und, hast du mit QoS dafür gesorgt das wenigstens ACK-Pakete
bevorzugt werden?

Die Anwendung, auch als Server (lauscht auf einem Port größer 1024) làuft
dazu nur mit User Rechten. Wie kann es da die Internet Verbindung zum
Abbruch bringen?



Wie dick ist deine DSL-Leitung? Làuft die mit einem Interleave (nicht
gut für die Latenz)? Benutzt du QoS auf dem Router? Ist der ut-server
auf der gleichen Maschine oder einem separeten Host?

Und wenn ich raten soll kommen viele anfragen schnell rein, aber der
Uplink ist durch den Map-download dicht so das die ACK-Pakete nicht
zügig genug raus gehen können.

Und die Echos deines pppd anscheinend auch nicht. Also denkt der der
Link ist tot und beendet.

Nur eine Vermutung, aber wenn's stimmt könnte ein QoS Setup helfen.

Kay
https://www.linuxcounter.net/cert/224140.png

Ähnliche fragen