Forums Neueste Beiträge
 

v4l im chroot

14/07/2008 - 22:52 von Martin Bley | Report spam
Hallo zusammen,

ich möchte meine webcam in einem 32Bit chroot betreiben. Leider mag v4l nicht
so richtig. Im chroot sagt

# v4l-info
/dev/video0: not an video4linux device

mehr nicht! Außerhalb des chroot sieht die Ausgabe desselben Kommandos so aus

# v4l-info

### video4linux device info [/dev/video0] ###
general info
VIDIOCGCAP
name : "Logitech QuickCam IM/Connect "
[...]

Das /dev Verzeichnis ist komplett im chroot gemounted (/dev/video0 ist
verfügbar)

Hat jemand hier eine grobe Richtung wo es langgeht?

Danke und Gruß,
Martin


Martin Bley
... aus Braunschweig
 

Lesen sie die antworten

#1 Hauke Laging
14/07/2008 - 23:33 | Warnen spam
Martin Bley schrieb am Montag 14 Juli 2008 22:52:

Hallo zusammen,

ich möchte meine webcam in einem 32Bit chroot betreiben. Leider mag
v4l nicht so richtig. Im chroot sagt

# v4l-info
/dev/video0: not an video4linux device

mehr nicht! Außerhalb des chroot sieht die Ausgabe desselben
Kommandos so aus

# v4l-info

### video4linux device info [/dev/video0] ###
general info
VIDIOCGCAP
name : "Logitech QuickCam IM/Connect "
[...]

Das /dev Verzeichnis ist komplett im chroot gemounted (/dev/video0
ist verfügbar)

Hat jemand hier eine grobe Richtung wo es langgeht?



Falls hier nichts Konkretes kommt: Lass doch mal beide Varianten
durch strace laufen und schau Dir an, wie der Zugriff aufs device
file in beiden Fàllen aussieht. Das mag schon erhellend sein.

Na, ja, ein Gedanke noch: Vielleicht kann der Kernel ein Modul nicht
nachladen, weil /lib(/...) nicht im chroot ist?


CU

Hauke
http://www.hauke-laging.de/ideen/
Wie können 59.054.087 Leute nur so dumm sein?

Ähnliche fragen