Variable Bereiche addieren

04/02/2008 - 13:34 von Dieter Schulz | Report spam
Hallo *,

ich kàmpfe (wieder) mit einem Excel-Problem.

Meine Tabelle bestehe aus vielen Zeilen, die wie folgt aufgebaut sind:
A1 = Text
B1 = Zahl (z.B.: 3)
C1 = Auswertung

in B2:B4 (3 Zeilen, weil B1=3 ist) steht jeweils ein Datum.

A5 = Text
B5 = Zahl
C5 = Auswertung
B6:Bx = Datum usw.

Ich will in C1 die Summe von C2:C4 berechnen.
C2:C4 sind Hilfszellen: IF B2>D$1 THEN 1 ELSE 0

Dazu habe ich die zwei Formeln in eine zusammengefasst:
=WENN(A1<>"";SUMME(BEREICH.VERSCHIEBEN(C2;0;0;INDIREKT("B1";WAHR);1));WENN(B1>$D$1;1;0))

Diese Formel wird in C1:Cnn kopiert.

Jetzt das Problem: Excel passt zwar beim Runterkopieren das "A1" und
"B2" an, nicht aber das "B1" in dem INDIREKT("B1";WAHR) :-(

Wie kann ich erreichen, dass auch das "B1" angepasst wird?

TIA
Dieter
Ach ja: gesucht ist eine Formellösung, keine VBA-Lösung
 

Lesen sie die antworten

#1 Alexander Wolff
04/02/2008 - 14:16 | Warnen spam
Jetzt das Problem: Excel passt zwar beim Runterkopieren das "A1" und
"B2" an, nicht aber das "B1" in dem INDIREKT("B1";WAHR) :-(



INDIREKT("B"&ZEILE(B1);WAHR) ausprobieren
Moin+Gruss Alexander - MVP for MS Excel - www.xxcl.de - mso2000sp3 --7-2

Ähnliche fragen