Variable externe Bezüge

15/07/2008 - 17:33 von Bjoern | Report spam
Moin!

Excel 2003 unter WXPPro

Ich möchte gerne externe Verweise auf dateien variabel halten.

Für zweidimensionale Bezüge geht das ja z.B. mit

=INDIREKT(ADRESSE(B9;B10)).

wenn in B9 eine 5 steht und in B10 eine 1, dann spuckt die Formel das aus,
was in A5 steht.
Benennt man B9 in 'zeile' und B10 in 'spalte', kann man schreiben:
=INDIREKT(ADRESSE(zeile;spalte))

Will man das Ganze auf andere Dateien erweitern, gibt's dafür ja noch
weitere Parameter


Was aber, wenn ich eine komplexere Formel wie diese habe
=SUMMEWENN('X:\[test.xls]Umsàtze'!$T:$T;[Kriterium];'X:\[test.xls]Umsàtze'!$M:$M)

und die Pfadangabe durch eine Variable ersetzen möchte?

Ich will also in eine benamste Zelle den Pfad reinschreiben, und dann in der
Formel den fest verdrahteten Pfad durch die Variable ersetzen.

Also sinngemàß so:
=SUMMEWENN(Pfad & "Umsàtze'!$T:$T";[Kriterium];Pfad & "Umsàtze'!$M:$M")

Nun möchte ich die Zelle, in der der Pfad steht, variieren, und entsprechend
sollen sich die Formelergebnisse àndern.

Hintergrund:
Ich habe verschiedene Stànde einer immer gleich aufgebauten Datei
abgespeichert, und will in einer Auswertungsdatei die unterschiedlichen
Stànde auswerten. Dazu will ich in eine Zelle den Pfad und den Dateinamen
eintippeln, und dann sollen sich alle Formeln entsprechend anpassen.

Das kriege ich ums Verrecken nicht hin.

Weiß einer wie das geht?

Danke und viele Grüße,
 

Lesen sie die antworten

#1 {Boris}
15/07/2008 - 22:35 | Warnen spam
Hi Bjoern,

On 15 Jul., 17:33, Bjoern wrote:
Moin!

Excel 2003 unter WXPPro

Ich möchte gerne externe Verweise auf dateien variabel halten.

Für zweidimensionale Bezüge geht das ja z.B. mit

=INDIREKT(ADRESSE(B9;B10)).

wenn in B9 eine 5 steht und in B10 eine 1, dann spuckt die Formel das aus,
was in A5 steht.
Benennt man B9 in 'zeile' und B10 in 'spalte', kann man schreiben:
=INDIREKT(ADRESSE(zeile;spalte))

Will man das Ganze auf andere Dateien erweitern, gibt's dafür ja noch
weitere Parameter

Was aber, wenn ich eine komplexere Formel wie diese habe:
=SUMMEWENN('X:\[test.xls]Umsàtze'!$T:$T;[Kriterium];'X:\[test.xls]Umsàtze'!­$M:$M)

und die Pfadangabe durch eine Variable ersetzen möchte?

Ich will also in eine benamste Zelle den Pfad reinschreiben, und dann in der
Formel den fest verdrahteten Pfad durch die Variable ersetzen.

Also sinngemàß so:
=SUMMEWENN(Pfad & "Umsàtze'!$T:$T";[Kriterium];Pfad & "Umsàtze'!$M:$M")

Nun möchte ich die Zelle, in der der Pfad steht, variieren, und entsprechend
sollen sich die Formelergebnisse àndern.

Hintergrund:
Ich habe verschiedene Stànde einer immer gleich aufgebauten Datei
abgespeichert, und will in einer Auswertungsdatei die unterschiedlichen
Stànde auswerten. Dazu will ich in eine Zelle den Pfad und den Dateinamen
eintippeln, und dann sollen sich alle Formeln entsprechend anpassen.

Das kriege ich ums Verrecken nicht hin.

Weiß einer wie das geht?



Prinzipiell geht das auch mit INDIREKT - Du musst nur den externen
Bezug exakt als String nachbilden und an INDIREKT übergeben -
allerdings müssen die Quelldateien dafür geöffnet sein, und das ist in
den meisten Fàllen nicht erwünscht.

Grüße Boris

Ähnliche fragen