Forums Neueste Beiträge
 

VB.net 2005, Crystal Reports 10, Problem beim Verteilen der Anwendung

18/12/2007 - 15:33 von Sascha | Report spam
Hallo.

Ich habe als Neuling im Bereich VB.net eine Anwendung erstellt,
mittels welcher Crystal Reports (Version 10) aufgerufen werden.
Da es auf dem Entwicklungsrechner natürlich làuft, wollte ich die
Anwendung auf einem Test PC laufen lassen (Win XP, SP2, .NET Framework
2.0).
Dafür habe ich in meiner Projektmappe ein neues Setup- Projekt
erstellt, über welches ich die Setup.exe erstellt habe. Auf dem
Entwicklungsrechner funktioniert die Exe sowie auch die installierte
Anwendung.
Die Exe funktioniert zwar, d.h. ich kann die Anwendung installieren,
aber wenn ich die Anwendung starten möchte, erscheint nichts.


Die Anwendung beinhaltet ein Formular mit Comboboxen und einem
CrystalReportViewer Objekt. Nach Auswahl in den Comboboxen erfolgt
ereignisgesteuert eine Abfrage, abhàngig von den ausgewàhlten Daten.
Diese Abfrage wird als XML Schema gespeichert. Das Schema ist die
Grundlage für einen Crystal Report.
Dies funktioniert soweit auf dem Entwicklungsrechner einwandfrei.

Auf zwei voneinander unabhàngigen Testrechnern wird die Anwendung
nicht gestartet (Umgebung oben beschrieben).

Die Verweise habe ich alle auf "Lokale Kopie" in der Anwendung
gestellt.


Vielleicht kann mir jemand weiterhelfen, so dass die Anwendung doch
noch laufen wird auf jedem gewünschten Rechner mit der entsprechenden
Umgebung.

Vielen Dank im Voraus.

Sascha
 

Lesen sie die antworten

#1 Thomas Wenning
18/12/2007 - 16:56 | Warnen spam
Hallo Sascha,

hast du auch die Merge-Modules eingebunden:
http://technicalsupport.businessobj...p;dialogID310861&stateId=1%200%2013316366

Gruß

Thomas Wenning

Ähnliche fragen