VBA Makro Urlaub in Kalender eintragen

22/12/2009 - 14:53 von RogHB346 | Report spam
Hallo


ich möchte in einem Kalender "Tabelle1" in der Spalte C den Urlaub mit
"U" kennzeichnen

1. "Taballe1" in der Spalte A start Zelle A1 das Datum von 01.01.2010
bis 31.12.2010 stehen.

2. Im Blatt "Tabelle2" habe ich die Daten für die Urlaubszeit

A B

1 05.01.2010 15.01.2010
2 14.02.2010 21.02.2010
3 20.05.2010 15.06.2010
4 01.11.2010 15.11.2010

Leider schaffe ich es noch nicht das richtig hin zu bekommen.
Wer kann helfen - Danke

MfG
Heinz
 

Lesen sie die antworten

#1 HelmutMit
22/12/2009 - 18:47 | Warnen spam
On 22 Dez., 14:53, RogHB346 wrote:
Hallo

ich möchte in einem Kalender "Tabelle1" in der Spalte C den Urlaub mit
"U" kennzeichnen

1. "Taballe1" in der Spalte A start Zelle A1 das Datum von 01.01.2010
bis 31.12.2010 stehen.

2. Im Blatt "Tabelle2" habe ich die Daten für die Urlaubszeit

                        A                                          B

1                05.01.2010                     15.01.2010
2               14.02.2010                      21.02.2010
3               20.05.2010                      15.06.2010
4               01.11.2010                      15.11.2010

Leider schaffe ich es noch nicht das richtig hin zu bekommen.
Wer kann helfen -  Danke

MfG
Heinz



Hallo Heinz,
der Einfachheit halber habe ich die Formel für Deine erste
Urlaubsspanne entwickelt.
Für die volle Schönheit musst Du halt benannte Formeln Urlaub1 bis 4
und benannte Zellen Anfang1 bis 4 und Ende1 bis 4 erstellen und die in
der Wenn-Bedingung Odern.
Deine Formel in B1 muss lauten:
=WENN(ISTZAHL(VERGLEICH($A1;Urlaub;0));"U";""),
dabei ist Urlaub eine benannte Formel:
=ZEILE(INDIREKT(Anfang & ":" & Ende)), die eine Matrix aufspannt von
allen Tagen zwischen Anfang und Ende.
Anfang und Ende sind die benannten Zellen für Urlaubsanfang
(14.2.2010) und Urlaubsende (21.2.2010).
Die Formel in B1 runterkopieren.

Gruß Helmut
www.excelmexel.de

Ähnliche fragen