VDPAU mit freiem radeon-Treiber unter Debian testing AMD64

26/09/2013 - 17:04 von Gabriel Schumann | Report spam
Hallo zusammen,

gerade versuche ich VDPAU mit dem freiem radeon-Treiber unter Debian
testing AMD64 zum laufen zu bekommen. Konkret verwende ich eine AMD
E-350-APU auf einem ASUS E35M1-I Deluxe.

Leider ist es schwierig herauszufinden, welche Voraussetzungen notwendig
sind bzw. welche Pakete in welcher Version vorliegen müssen. An einer
Stelle war davon die Rede, dass folgende Pakete mindestens vorhanden
sein müssen:

Kernel >= 3.10
libdrm >= 2.4.45
mesa >= 9.2 mit Option "- with-Gallium-drivers = r600 - enable-vdpau"

Ist diese Auflistung korrekt? Dann müsste ich nàmlich erst einmal auf
mesa 9.2 warten, aktuell ist 9.1.6, der Rest passt.

Wie dem auch sei, ich habe das System vor kurzem neu aufgesetzt und u.
A. die Pakete libvdpau, vdpau-va-driver und vdpauinfo nachinstalliert.
Wenn ich vdpauinfo aufrufe, bekomme ich folgende Fehlermeldung:

display: :0 screen: 0
Failed to open VDPAU backend libvdpau_r600.so: cannot open shared object
file: No such file or directory
Error creating VDPAU device: 1

Wenn man nach dieser Fehlermeldung im Netz sucht, bekommt man viele
Ergebnisse, jedoch keine, die hilfreich sind, da VDPAU erst seit Kurzem
unterstützt wird, und die meisten Ergebnisse sich auf andere Probeme
beziehen.

Was muss ich tun, damit es làuft? Reicht es, einfach auf die nàchste
mesa-Version zu warten? Das wàre mir jedenfalls lieber als irgendwas von
Git zu kompilieren...

Gruß

Gabriel
 

Lesen sie die antworten

#1 Henning Paul
27/09/2013 - 08:44 | Warnen spam
Gabriel Schumann schrieb:

gerade versuche ich VDPAU mit dem freiem radeon-Treiber unter Debian
testing AMD64 zum laufen zu bekommen. Konkret verwende ich eine AMD
E-350-APU auf einem ASUS E35M1-I Deluxe.



Unter openSUSE 12.3 habe ich das erfolgreich hinbekommen, mit Paketen
aus dem Buildservice.

Leider ist es schwierig herauszufinden, welche Voraussetzungen
notwendig sind bzw. welche Pakete in welcher Version vorliegen müssen.
An einer Stelle war davon die Rede, dass folgende Pakete mindestens
vorhanden sein müssen:

Kernel >= 3.10
libdrm >= 2.4.45
mesa >= 9.2 mit Option "- with-Gallium-drivers = r600 - enable-vdpau"

Ist diese Auflistung korrekt?



Ja.

Dann müsste ich nàmlich erst einmal auf mesa 9.2 warten,



Unbedingt.

Wenn ich vdpauinfo aufrufe, bekomme ich folgende Fehlermeldung:

display: :0 screen: 0
Failed to open VDPAU backend libvdpau_r600.so: cannot open shared
object file: No such file or directory



Das liegt daran, dass mesa < 9.2 diese Library nicht mitbringt.

Was muss ich tun, damit es làuft? Reicht es, einfach auf die nàchste
mesa-Version zu warten?



Würde ich erwarten.

Das wàre mir jedenfalls lieber als irgendwas
von Git zu kompilieren...



git-Versionen brauchst Du nicht, mesa 9.2 ist stabil. Hat unstable
vielleicht schon ein 9.2-Paket?

Gruß
Henning

Ähnliche fragen