Verbindung zum SQL Server

08/05/2008 - 08:46 von andi rickenbach | Report spam
Hallo,

ich habe eine vb.net Applikation, welche auf eine MS SQL Server Datenbank
zugreift.
Die Applikation und der Server laufen auf demselben PC.
Der PC steht in China und ich kann mit Fernwartung auf diesen zugreifen,
habe aber wenig Möglichkeiten zu
debuggen oder diesen Fehler so zu suchen, desshalb wàre ich um jeden Tipp
froh!

Wenn ich der PC neu starte und mit der Applikation auf die Datenbank
zugreifen möchte,
kommt eine Exception - Meldung "Could not connect to database".
Ich warte dann etwa drei Minuten und versuche erneut die Applikation zu
starten und dann funktioniert das plötzlich wieder.
Ab jetzt ist immer alles in Ordnung bis ich der PC wieder neu starte.

Folgende Infos habe ich noch dazu:
- Mehrere male die Applikation starten bringt nichts solange nicht eine
gewisse Zeit (eben etwa 3 Minuten) verstrichen ist.
- An der Applikation kann es nicht liegen, denn es sind genau gleiche PC's
mit genau gleicher Software im einsatz und das funktioniert tadellos.
- Der PC hat die IP-Adresse 192.168.50.100. Ich habe festgestellt, das ein
Ping auf diese IP nicht funktioniert,
genau solange wie die Applikation auch nicht aufgestartet werden kann.
Sobald der Ping funktioniert, làuft auch die Applikation wieder (nun hatte
ich der Verdacht auf ein Problem des Netzwerks).
Hier eine Frage dazu, was hat der SQL-Server genau mit dem Netzwerk zu tun?
Der Server und die Applikation sind ja auf gleichem Rechner!
Ist mir bewusst das ich über TCP/IP auch von meinem Laptop aus auf die DB
zugreifen kann aber was könnte das für einen
Zusammenhang haben (Ping und Connect zur DB)?
- Zugriff über das Management Studio auf die DB ist zu jederzeit ok.

Vielen Dank für eure Tipps.
 

Lesen sie die antworten

#1 Winfried Sonntag [MVP]
08/05/2008 - 09:27 | Warnen spam
andi rickenbach schrieb:

Wenn ich der PC neu starte und mit der Applikation auf die Datenbank
zugreifen möchte,
kommt eine Exception - Meldung "Could not connect to database".
Ich warte dann etwa drei Minuten und versuche erneut die Applikation zu
starten und dann funktioniert das plötzlich wieder.
Ab jetzt ist immer alles in Ordnung bis ich der PC wieder neu starte.



Asynchrones Startverhalten von XP nennt sich das. Es wird seit XP
versucht, möglich schnell den Desktop zu zeigen, d.h. den Explorer zu
laden, alles andere wird nach und nach geladen/gestartet.

- Der PC hat die IP-Adresse 192.168.50.100. Ich habe festgestellt, das ein
Ping auf diese IP nicht funktioniert,



Weil das "Netzwerk" des Clients noch nicht bereit ist.

genau solange wie die Applikation auch nicht aufgestartet werden kann.
Sobald der Ping funktioniert, làuft auch die Applikation wieder (nun hatte
ich der Verdacht auf ein Problem des Netzwerks).



Nein, kein Problem vom Netzwerk, sondern ein sehr bekanntes von XP. Ist
der Client in einer Windows Domain? Wenn ja, dann aktiviere die beiden
Einstellungen aus der No. 36:
http://www.gruppenrichtlinien.de/Gr...en/faq.htm
Wenn der Client Standalone ist, dann mach es lokal via GPEDIT.MSC.
Anschließend 2 x neu starten, dann sollte es besser funktionieren.

Servus
Winfried
KnowHow.mdb: http://www.freeaccess.de/knowhow.asp
Access-FAQ: http://www.donkarl.com/AccessFAQ.htm
Access-Stammtisch: http://www.access-muenchen.de/
Richtig zitieren: http://einklich.net/usenet/zitier.htm

Ähnliche fragen