Verbundenes Formular funktioniert nicht mehr richtig

12/12/2008 - 09:12 von Volker Neurath | Report spam
Hallo zusammen,

nachdem ihr jetzt einige Rochen Ruhe vor mir hattet, muss ich euch mit
einem neuen Problem nerven.

In meiner kleinen Datenbank habe ich ein Endlosformular mit 4 Feldern
und einem Toggle-Button; diese Button öffnet ein Child-Form, auf dem
Detaildaten zu dem Datensatz angezeigt werden, bei dem der Button
geklickt wurde.
Bis hierher funktioniert alles, das Child-Form zeigt hier die Korrekten
Daten.

Aber: wenn ich in diesem Child-Form ein neues Detaildatum zu diesem DS
eintragen möchte (es geht um Statusinformationen zu Angeboten) dann muss
ich die betreffende Angebotsnummer manuell in das entsprechende Feld
eintragen warum?
Und wie bekomme ich es hin, dass das Feld auch im neuen Detaildatensatz
vorbelegt ist?

Ich meine mich entsinnen zu können, dass es schon mal korrekt
funktioniert hat aber ich finde einfach den Fehler nicht.

Volker

Wenn es vom Himmel Zitronen regnet -- lerne, Limonade zu machen.
 

Lesen sie die antworten

#1 Karl Donaubauer
12/12/2008 - 10:09 | Warnen spam
Volker Neurath wrote:
nachdem ihr jetzt einige Rochen Ruhe vor mir hattet, muss ich euch mit
einem neuen Problem nerven.



Joo, du hast schon gefehlt. ;-)

In meiner kleinen Datenbank habe ich ein Endlosformular mit 4 Feldern
und einem Toggle-Button; diese Button öffnet ein Child-Form, auf dem
Detaildaten zu dem Datensatz angezeigt werden, bei dem der Button
geklickt wurde.
Bis hierher funktioniert alles, das Child-Form zeigt hier die Korrekten
Daten.

Aber: wenn ich in diesem Child-Form ein neues Detaildatum zu diesem DS
eintragen möchte (es geht um Statusinformationen zu Angeboten) dann muss
ich die betreffende Angebotsnummer manuell in das entsprechende Feld
eintragen warum?
Und wie bekomme ich es hin, dass das Feld auch im neuen Detaildatensatz
vorbelegt ist?

Ich meine mich entsinnen zu können, dass es schon mal korrekt
funktioniert hat aber ich finde einfach den Fehler nicht.



Ich auch nicht, aber wie wàre es damit?

DoCmd.OpenForm "DetailFormular", , , _
"Angebotsnummer = " & Me!Angebotsnummer

If Forms!DetailFormular.NewRecord Then
Forms!DetailFormular!Angebotsnummer = Me!Angebotsnummer

'falls du mehrere Detaildatensàtze eingeben willst, vielleicht noch:
'Forms!DetailFormular!Angebotsnummer.DefaultValue = Me!Angebotsnummer
End If

Falls das nicht klappen sollte, dann verrate den genauen Fehler,
deinen Code und alle beteiligten Objekt- und Feldnamen.

HTH
Karl
********* Ich beantworte keine Access-Fragen per Email. *********
Access-FAQ: http://www.donkarl.com

Ähnliche fragen