Vergleich mit 2 Spalten

12/03/2009 - 12:15 von Hitdrummer | Report spam
Hallo,

ich bin auf der Suche nach der Lösung für folgendes Problem:

Habe in Spalte A "PLZ-Codes" diese sind Abhàngig von den PLZ. (hier 1 - 9

in Spalte B "bis-Gew" (90; 150; 250; 500...) (abhàngig vom tats.
Gewicht)

Ca. 700 Zeilen mit den 72 verschiedenen Möglichkeiten z.B. 2 150 oder 6
90


In einer zweiten Tabelle habe ich 3 Spalten:

A B C
1 1 90 16,25
2 1 150 0,298
3 1 250 0,368
4 1 500 0,638
5 2 90 17,58
6 2 150 0,275
7 2 250 0,357 .


In Tabelle 1 Spalte C möchte ich nun die Preise von Tabelle 2, Spalte C
einsetzen lassen.

Hab es mit Sverweis versucht, hat aber nicht geklappt.

Bitte um Hilfe!!!!


DANKE
 

Lesen sie die antworten

#1 Melanie Breden
12/03/2009 - 12:53 | Warnen spam
Hallo,

"Hitdrummer"schrieb:
Habe in Spalte A "PLZ-Codes" diese sind Abhàngig von den PLZ. (hier 1 - 9

in Spalte B "bis-Gew" (90; 150; 250; 500...) (abhàngig vom tats.
Gewicht)

Ca. 700 Zeilen mit den 72 verschiedenen Möglichkeiten z.B. 2 150 oder 6
90


In einer zweiten Tabelle habe ich 3 Spalten:

A B C
1 1 90 16,25
2 1 150 0,298
3 1 250 0,368
4 1 500 0,638
5 2 90 17,58
6 2 150 0,275
7 2 250 0,357 .


In Tabelle 1 Spalte C möchte ich nun die Preise von Tabelle 2, Spalte C
einsetzen lassen.



ich gehe davon aus, dass die Daten in Tabelle 2 ebenfalls eine Überschriftenzeile haben.

Versuche dann folgende Formel in C2 der Tabelle1und kopiere sie nach unten:

=SVERWEIS(B2;BEREICH.VERSCHIEBEN(Tabelle2!$A$1;VERGLEICH(A2;Tabelle2!A2:A73;0);;
ZÄHLENWENN(Tabelle2!A2:A73;A2);3);3;WAHR)


Mit freundlichen Grüssen
Melanie Breden

- Microsoft MVP für Excel -
www.melanie-breden.de

Ribbon-Programmierung für Office 2007 http://tinyurl.com/59awla

Ähnliche fragen