Vergleich über drei Tabellenblätter

30/10/2009 - 11:11 von Jan-Thomas Kühnert | Report spam
Hallo,

ich habe drei Tabellenblàtter. Im dritten ist eine Zusammenfassung mit
Meßergebnissen. Diese werden durch die Spalten A und B identifiziert. In
den beiden anderen Tabellenblàttern sind die Rohdaten erfaßt, zu denen
die Ergebnisse aus Blatt 3 zugeordnet werden sollen. Auch hier sind die
identifizierenden Spalten jeweils A und B.

Ich vergleiche im Moment hàndisch Spalte A Blatt 1 mit Spalte A Blatt 3.
Bei Gleichheit vergleiche ich nun Spalte B Blatt 1 mit Spalte B Blatt 3.
Anschließend wird bei Gleichheit beider Spalten der gefundene Inhalt der
Zeile aus Blatt 1 in Blatt 4 kopiert (Spalten A bis N), dahinter der
Inhalt der namensgleichen Zeile aus Blatt 3 (Spalten A bis L).

Zu vergleichen sind 2700 Datensàtze...

Habe ich mich verstàndlich ausgedrückt? Wenn ja, ist mir helfen?

Vielen Dank im voraus,
Jan-Thomas
 

Lesen sie die antworten

#1 Andreas Killer
30/10/2009 - 12:26 | Warnen spam
On 30 Okt., 11:11, Jan-Thomas Kühnert wrote:

Ich vergleiche im Moment hàndisch Spalte A Blatt 1 mit Spalte A Blatt 3.
Bei Gleichheit vergleiche ich nun Spalte B Blatt 1 mit Spalte B Blatt 3.
Anschließend wird bei Gleichheit beider Spalten der gefundene Inhalt der
Zeile aus Blatt 1 in Blatt 4 kopiert (Spalten A bis N), dahinter der
Inhalt der namensgleichen Zeile aus Blatt 3 (Spalten A bis L).


Schreib in Blatt4 in Zelle AA1 die Formel
=UND(Blatt1!A1=Blatt3!A1;Blatt2!B1=Blatt3!B1)

Damit erhàlst Du das Ergebnis des Vergleichs WAHR oder FALSCH.

In Zelle A1 schreibst Du die Formel
=WENN($AA1;Blatt1!A1;"")
und ziehe sie bis Spalte N und dann runter soweit Deine Daten reichen.

In Zelle O1 die Formel
=WENN($AA1;Blatt2!A1;"")
und ziehe sie bis Spalte Z und dann runter soweit Deine Daten reichen.

Noch einen Autofilter gesetzt und alle FALSCH in Spalte AA
weggefiltert sollte das passende Ergebnis bringen.

Andreas.

Ähnliche fragen