Verschachtelte Abfrage

24/06/2008 - 15:40 von Holger D. | Report spam
Hallo ihr Lieben,

ich bin schon seit làngerem auf der Suche nach einer Lösung folgender
Problematik:

A B
1 Ofen 1
2 Ofen 2
1 Ofen 3
3 Ofen 4
1 Ofen 5

Nun habe ich eine weitere Tabelle, die die Werte der Spalte A singulàr
enthàlt; also 1, 2, 3. Nun möchte ich dort hinter jeweils den Eintrag aus der
angegebenen Spalte B vermerken. Also:

A B C D E
1 Ofen 1 Ofen 3 Ofen 5
2 ... ...

Könnte ich sowas mit einer Formel in Excel lösen? Das wàre super!

Ganz herzlichen Dank schon jetzt für die Hilfe.

Schöne Grüße
Holger
 

Lesen sie die antworten

#1 {Boris}
24/06/2008 - 16:06 | Warnen spam
Hi Holger,

On 24 Jun., 15:40, Holger D.
wrote:
Hallo ihr Lieben,

ich bin schon seit làngerem auf der Suche nach einer Lösung folgender
Problematik:

 A          B
1           Ofen 1
2           Ofen 2
1           Ofen 3
3           Ofen 4
1           Ofen 5

Nun habe ich eine weitere Tabelle, die die Werte der Spalte A singulàr
enthàlt; also 1, 2, 3. Nun möchte ich dort hinter jeweils den Eintrag aus der
angegebenen Spalte B vermerken. Also:

A       B          C          D          E
1       Ofen 1  Ofen 3   Ofen 5
2       ...        ...

Könnte ich sowas mit einer Formel in Excel lösen? Das wàre super!



Dein Quelldatenblatt heißt Tabelle1. Dann in die andere Tabelle in in
A1:A... die Unikate (1,2,3 etc.) eintragen.
In B1 diese Arrayformel und dann nach rechts UND nach unten kopieren:

{=WENN(SPALTEN($A:A)>ZÄHLENWENN(Tabelle1!$A:$A;$A1);"";INDEX(Tabelle1!
$B:$B;KKLEINSTE(WENN(Tabelle1!$A$1:$A$100$A1;ZEILE($1:$100));SPALTEN($A:A))))}

{geschweifte Klammern} nicht eingeben, sondern Formeleingabe mit
gleichzeitig Strg+Shift+Enter abschließen.

Grüße Boris

Ähnliche fragen