Version and compatibility Access 2003 sql-server 2005

22/01/2010 - 17:40 von Max Leibundgut | Report spam
I use sql-server 9.0.3077 and as frontend Access 2003 SP3 11.8166.8221
This works normally since long time, with mgmt studio I can maintain the db
When I try to make a db.diagram with mgmt studio or I try to make a query
from an adp-project I get the following message:
"Sie haben sich mit einer Version von SQL Server verbunden, die neuer als
SQL Server 2000 ist. Sowohl Visual Studio 7.0 als auch Access 2000 wurden
vor der Version von SQL Server herausgegeben, mit der sie verbunden sind.
Deshalb könnten Probleme auftreten.
Kontaktieren Sie Microsoft, und fragen Sie nach einem Service Pack für
Visual Studio oder Office, um Support für die Version von SQL Server zu
enthalten, mit der Sie verbunden sind.
Sie können fortfahren, aber alle neuen Objekttypen könnten u.U. nicht
aufgezàhlt sein, und es wird nicht möglich sein, Objekte und
Datenbankdiagramme zu speichern, die Sie mit den Visual Datenbanktools
erstellt haben."
In db properties options I can adjust the compatibility level to 7, 2000 or
2005
but this doesn't help.
What else can I do?
Thanks Max Leibundgut
 

Lesen sie die antworten

#1 Peter Doering
22/01/2010 - 18:03 | Warnen spam
Hallo,

Max Leibundgut wrote:

I use sql-server 9.0.3077 and as frontend Access 2003 SP3 11.8166.8221
This works normally since long time, with mgmt studio I can maintain the db
When I try to make a db.diagram with mgmt studio or I try to make a query
from an adp-project I get the following message:
"Sie haben sich mit einer Version von SQL Server verbunden, die neuer als
SQL Server 2000 ist. Sowohl Visual Studio 7.0 als auch Access 2000 wurden
vor der Version von SQL Server herausgegeben, mit der sie verbunden sind.
Deshalb könnten Probleme auftreten.
Kontaktieren Sie Microsoft, und fragen Sie nach einem Service Pack für
Visual Studio oder Office, um Support für die Version von SQL Server zu
enthalten, mit der Sie verbunden sind.
Sie können fortfahren, aber alle neuen Objekttypen könnten u.U. nicht
aufgezàhlt sein, und es wird nicht möglich sein, Objekte und
Datenbankdiagramme zu speichern, die Sie mit den Visual Datenbanktools
erstellt haben."
In db properties options I can adjust the compatibility level to 7, 2000 or
2005
but this doesn't help.
What else can I do?



Nix. Objektaenderungen im ADP sind nur bis SQL 2000 moeglich. Wenn du was
aendern willst -> SSMS.

Gruss - Peter

Mitglied im http://www.dbdev.org
FAQ: http://www.donkarl.com

Ähnliche fragen