Verständnisfrage Grub Error 17 Fehleranalyse.

04/04/2008 - 17:01 von Ottmar Ohlemacher | Report spam
(Falls hier /merkwürdige/ Zeichen (hier sieht es aus wie Kàstchen)
auftauchen, dann liegt das daran, dass ich den Text in meinem Knoppix
geschrieben hab, auf USB-Stick kopiert hab und dann von Win ins Usenet
geschickt hab - einen Newsreader ein einer Knoppix-Live-CD einzurichten für
ein einziges Posting erschien mir etwas zu viel Aufwand für ein einezelnes
Posting - danke für Verstàndnis)



Hallo,



ich hab zunàchst mal nur ne Verstàndnisfrage zu nem Fehler, bzw wie und
wo der Fehler eingeschlichen. Die Beseitung werd ich dann wohl
(hoffentlich) auch noch hinbekommen...

Also folgends ...

ich hab auf
meiner Spiel/Test/Probierplatte auf den ersten drei primàren Partitionen
ein WinXP (sda2), ein Debian Etch (sda3), die Swap-Partition(sda4) und ganz
zum Schluß noch die Erweiterte Partition (sda1), in der sich die logische
Partition (sda5) befindet.

Gebootet wurde mit Grub, und das funktionierte
auch alles so weit, bis ich dann mein (ausprobier)WinXP kaputtausprobiert
hatte, und es Zeit war, ein neues Image für WinXP aufzuziehen. Da ich von
früher[tm] her schon wusste, dass bei der Aktion meist auch der
Masterbootrecord überschieben wird, hab ich den Masterbootrecord mit
Knoppix auf einen USB-Skick gesichert mit dd if=/dev/sda
of=/media/sdb1/dateipfad/mbr bsQ2 count=1 Danach hab ich mit TrueImage
von USB-Platte das "original-fabrikmàßige" WinXP (samt MBR) aufgezogen, mit
dem Ergebins, das WinXP booten konnte, aber Grub weg war.

Nun den habich
mir gedacht habich mir, dann werd ich mit Knoppix halt den zuvor auf
USB-Stick gesicherten mbr wieder zurückkopieren. Also...das dürfte jetzt
der Befehl:
dd if=/media/sdb1/dateipfad/mdb of=/dev/sda sein.

Leider
bekomme ich jetzt beim booten die Meldung:

Grub làd...

Error 17


Tja -
jetzt würde mich interessieren, wo sich da jetzt da wohl der Fehler
eingeschlichen haben mag.


Nach meinem Verstàndnis sollte zumindest Grub
jetzt funktionieren, denn selbst wenn AcronisTrueImage etwas an der
Partittiontabelle geàndert haben mag (sowas wird dem Programm nachgesagt),
dann sollte doch mit dem Zurückspielen des MBR dieser Fehler doch wieder
korrigiert sein, denn die Partitionstabelle ist doch wohl ein Teil des MBR,
und wurde ja schließlich zurückgesichert.

Falls jemand weiß, wo ich hier
einen Denkfehler hab, würde mich das sicher weiterbringen.



Gruß + Dank



Ottmar
 

Lesen sie die antworten

#1 Martin Fuchs
04/04/2008 - 17:24 | Warnen spam
Grub làd...

Error 17




Diesen Fehler habe ich auch mal im Zusammenhang mit zurückgespielten
Partitionen bekommen, siehe:
"openSuSE 10.3 - S-ATA-Problem beim Klonen" vom 05.03.08
news://news.individual.net:119/

Vielleicht hat es bei dir auch was mit unterschiedlichen
Adressierungen der S-ATA-Laufwerke zu tun, weil du evtl.
beim Klonen/Zurückspielen/Neu booten zusàtzliche Wechsellaufwerke
im Rechner hattest.


mf

Ähnliche fragen