Verständnisfrage zu radeon und glxgears

29/07/2015 - 11:50 von Michael Lange | Report spam
Hallo Liste,
es gab ja zuletzt einen làngeren Thread zu Problemen mit dem radeon
Treiber, in dem auch Tests zur 3D Beschleunigung mittels glxgears
besprochen wurden. Bei mir (RS780L Onboard Grafik, Jessie) funktioniert
das System an sich, aber nur aus Neugierde (und da ich mich mit 3D an sich
auf diesem Rechner noch gar nicht weiter befasst hatte), habe ich dann
auch mal glxgears laufen lassen und bekam allerdings nur so etwas als
Ausgabe:

$ glxgears
Running synchronized to the vertical refresh. The framerate should be
approximately the same as the monitor refresh rate.
300 frames in 5.0 seconds = 59.883 FPS
299 frames in 5.0 seconds = 59.747 FPS

Ok, ein bisschen suchen und ich fand heraus, dass ich dies beheben kann
durch:

$ vblank_mode=0 glxgears
ATTENTION: default value of option vblank_mode overridden by environment.
4765 frames in 5.0 seconds = 952.936 FPS
4759 frames in 5.0 seconds = 951.675 FPS

Was mir allerdings jetzt nicht klar ist (und wozu ich auch nichts finden
konnte), ist das "vblank_mode=0" jetzt nur etwas, was man zum korrekten
funktionieren von glxgears einsetzen muss, oder müsste ich das
prinzipiell systemweit festlegen, damit 3D im Zweifelsfall mit anderen
Anwendungen funktioniert.
Eine xorg.conf gibt es hier bei mir nicht, die Grafik funnktioniert
"einfach so", im Xorg.0.log sehe ich beim durch sehen auch nichts
verdàchtiges, die Firmware wird geladen, KMS enabled etc., sieht für
meine Augen alles gut aus.

Vielen Dank im Voraus für Erklàrungen!

Michael



.-.. .. ...- . .-.. -. --. .- -. -.. .--. .-. ... .--. . .-.

The face of war has never changed. Surely it is more logical to heal
than to kill.


Zum AUSTRAGEN schicken Sie eine Mail an debian-user-german-REQUEST@lists.debian.org
mit dem Subject "unsubscribe". Probleme? Mail an listmaster@lists.debian.org (engl)
Archive: https://lists.debian.org/2015072911...4389fe2f58@freenet.de
 

Lesen sie die antworten

#1 Martin Steigerwald
29/07/2015 - 12:20 | Warnen spam
Am Mittwoch, 29. Juli 2015, 11:44:54 schrieb Michael Lange:
Hallo Liste,
es gab ja zuletzt einen làngeren Thread zu Problemen mit dem radeon
Treiber, in dem auch Tests zur 3D Beschleunigung mittels glxgears
besprochen wurden. Bei mir (RS780L Onboard Grafik, Jessie) funktioniert
das System an sich, aber nur aus Neugierde (und da ich mich mit 3D an sich
auf diesem Rechner noch gar nicht weiter befasst hatte), habe ich dann
auch mal glxgears laufen lassen und bekam allerdings nur so etwas als
Ausgabe:

$ glxgears
Running synchronized to the vertical refresh. The framerate should be
approximately the same as the monitor refresh rate.
300 frames in 5.0 seconds = 59.883 FPS
299 frames in 5.0 seconds = 59.747 FPS

Ok, ein bisschen suchen und ich fand heraus, dass ich dies beheben kann
durch:

$ vblank_mode=0 glxgears
ATTENTION: default value of option vblank_mode overridden by environment.
4765 frames in 5.0 seconds = 952.936 FPS
4759 frames in 5.0 seconds = 951.675 FPS

Was mir allerdings jetzt nicht klar ist (und wozu ich auch nichts finden
konnte), ist das "vblank_mode=0" jetzt nur etwas, was man zum korrekten
funktionieren von glxgears einsetzen muss, oder müsste ich das
prinzipiell systemweit festlegen, damit 3D im Zweifelsfall mit anderen
Anwendungen funktioniert.



Das wirkt so erstmal nur auf glxgears. Ob auch andere Anwendungen diese
Variable unterstützen, weiß ich nicht.

Es gibt aber Spiele, in denen das einstellbar ist. Z.B. beim openmw-launcher,
der die freie Engine für Morrowind – The Elderscrolls startet.

Ich persönlich sehe keinen Grund für eine Framerate, die die Refresh-Zeit des
Displays überschreitet, da ich davon ausgehe, dass die dann eh nicht sichtbar
ist, da das Display sie nicht darstellen kann.

Ciao,
Martin


Zum AUSTRAGEN schicken Sie eine Mail an
mit dem Subject "unsubscribe". Probleme? Mail an (engl)
Archive: https://lists.debian.org/

Ähnliche fragen