Verständnisproblem zu apt

28/08/2016 - 22:40 von Kai Wassermann | Report spam
Moin,

ich habe nach einem "apt-get dist-upgrade" kein X11 mehr. Das könnte ich
wohl lösen, möchte aber zuerst verstehen, warum das passiert ist.

Zunàchst Auszüge aus /var/log/apt/history.log (ja, das Problem existiert
schon seit fast einem Monat), dann noch ein paar Infos, über das jetzt
laufende System (uname -a, sources.list, xorg.conf).
Installiert habe ich das mal nach dieser Anleitung:
https://wiki.debian.org/NvidiaGraph...cy_GPUs.29
die Hardware ist nàmlich ein MacBook Pro.

Zusàtzliche Infos liefere ich gerne nach.

Viele Grüße

Kai



Start-Date: 2016-08-03 22:27:07
Commandline: apt-get upgrade
Upgrade: google-chrome-stable:amd64 (52.0.2743.82-1, 52.0.2743.116-1),
iceweasel:amd64 (45.2.0esr-1~deb8u1, 45.3.0esr-1~deb8u1), curl:amd64
(7.38.0-4+deb8u3, 7.38.0-4+deb8u4), firefox-esr:amd64
(45.2.0esr-1~deb8u1, 45.3.0esr-1~deb8u1), libcurl3:amd64
(7.38.0-4+deb8u3, 7.38.0-4+deb8u4), libcurl3-gnutls:amd64
(7.38.0-4+deb8u3, 7.38.0-4+deb8u4)
End-Date: 2016-08-03 22:27:42

Start-Date: 2016-08-03 22:39:38
Commandline: apt-get dist-upgrade
Install: libnvidia-legacy-304xx-glcore:amd64 (304.131-8~bpo8+1,
automatic), libnvidia-legacy-304xx-glcore:i386 (304.131-8~bpo8+1,
automatic), libnvidia-cfg1:amd64 (352.79-10~bpo8+1, automatic),
libnvidia-legacy-304xx-cfg1:amd64 (304.131-8~bpo8+1, automatic),
libopenjp2-7:amd64 (2.1.0-2, automatic),
nvidia-legacy-304xx-vdpau-driver:amd64 (304.131-8~bpo8+1, automatic),
libnvidia-glcore:amd64 (352.79-10~bpo8+1, automatic),
libnvidia-glcore:i386 (352.79-10~bpo8+1, automatic),
libnvidia-legacy-304xx-ml1:amd64 (304.131-8~bpo8+1, automatic),
nvidia-legacy-304xx-driver-libs:amd64 (304.131-8~bpo8+1, automatic),
nvidia-driver-libs:amd64 (352.79-10~bpo8+1, automatic),
nvidia-legacy-304xx-driver-bin:amd64 (304.131-8~bpo8+1, automatic)
Upgrade: nvidia-alternative:amd64 (352.79-8~bpo8+1, 352.79-10~bpo8+1),
libegl1-nvidia:amd64 (352.79-8~bpo8+1, 352.79-10~bpo8+1),
libgles2-nvidia:amd64 (352.79-8~bpo8+1, 352.79-10~bpo8+1),
nvidia-driver:amd64 (352.79-8~bpo8+1, 352.79-10~bpo8+1),
xserver-xorg-video-nvidia:amd64 (352.79-8~bpo8+1, 352.79-10~bpo8+1),
libgl1-nvidia-legacy-304xx-glx:amd64 (304.131-3~bpo8+1,
304.131-8~bpo8+1), libgl1-nvidia-legacy-304xx-glx:i386
(304.131-3~bpo8+1, 304.131-8~bpo8+1), nvidia-kernel-support:amd64
(352.79-8~bpo8+1, 352.79-10~bpo8+1), libgl1-nvidia-glx:amd64
(352.79-8~bpo8+1, 352.79-10~bpo8+1), libgl1-nvidia-glx:i386
(352.79-8~bpo8+1, 352.79-10~bpo8+1), nvidia-legacy-304xx-driver:amd64
(304.131-3~bpo8+1, 304.131-8~bpo8+1),
xserver-xorg-video-nvidia-legacy-304xx:amd64 (304.131-3~bpo8+1,
304.131-8~bpo8+1), libgles1-nvidia:amd64 (352.79-8~bpo8+1,
352.79-10~bpo8+1), libnvidia-ml1:amd64 (352.79-8~bpo8+1,
352.79-10~bpo8+1), libavcodec57:amd64 (3.0.2-2~bpo8+1, 3.0.2-4~bpo8+1),
nvidia-vdpau-driver:amd64 (352.79-8~bpo8+1, 352.79-10~bpo8+1),
nvidia-driver-bin:amd64 (352.79-8~bpo8+1, 352.79-10~bpo8+1),
nvidia-legacy-304xx-alternative:amd64 (304.131-3~bpo8+1,
304.131-8~bpo8+1), libnvidia-eglcore:amd64 (352.79-8~bpo8+1,
352.79-10~bpo8+1)
End-Date: 2016-08-03 22:41:01

Start-Date: 2016-08-03 22:56:08
Commandline: apt-get install mesa-utils
Install: mesa-utils:amd64 (8.2.0-1)
End-Date: 2016-08-03 22:56:21

Start-Date: 2016-08-05 19:35:01
Commandline: apt-get upgrade
Upgrade: openjdk-7-jre-headless:amd64 (7u101-2.6.6-2~deb8u1,
7u111-2.6.7-1~deb8u1), openjdk-7-jre:amd64 (7u101-2.6.6-2~deb8u1,
7u111-2.6.7-1~deb8u1)
End-Date: 2016-08-05 19:35:26

Start-Date: 2016-08-07 12:30:24
Commandline: apt-get autoremove
Remove: libnvidia-legacy-304xx-glcore:i386 (304.131-8~bpo8+1),
libgl1-nvidia-glx-i386:i386 (352.79-8~bpo8+1), libnvidia-glcore:i386
(352.79-10~bpo8+1), libgl1-nvidia-legacy-304xx-glx:i386
(304.131-8~bpo8+1), libgl1-nvidia-legacy-304xx-glx-i386:i386
(304.131-1), libgl1-nvidia-glx:i386 (352.79-10~bpo8+1), libxvmc1:i386
(1.0.8-2+b1)
End-Date: 2016-08-07 12:31:01


Linux debbook 4.4.0-0.bpo.1-amd64 #1 SMP Debian 4.4.6-1~bpo8+1
(2016-03-20) x86_64 GNU/Linux

deb tor+http://ftp.uni-koeln.de/debian/ jessie main contrib non-free
deb-src tor+http://ftp.uni-koeln.de/debian/ jessie main contrib non-free

deb tor+http://security.debian.org/ jessie/updates main contrib non-free
deb-src tor+http://security.debian.org/ jessie/updates main contrib non-free

# jessie-updates, previously known as 'volatile'
deb tor+http://ftp.uni-koeln.de/debian/ jessie-updates main contrib non-free
deb-src tor+http://ftp.uni-koeln.de/debian/ jessie-updates main contrib
non-free

#Backports
deb tor+http://ftp.uni-koeln.de/debian/ jessie-backports main contrib
non-free
deb-src tor+http://ftp.uni-koeln.de/debian/ jessie-backports main
contrib non-free

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 340.46 (buildd@brahms) Tue Oct 7 08:00:32
UTC 2014

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 28.0 - 33.0
VertRefresh 43.0 - 72.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
EndSubSection
EndSection

 

Lesen sie die antworten

#1 Richard Kraut
29/08/2016 - 20:00 | Warnen spam

Am Sonntag, den 28.08.2016, 22:38 +0200 schrieb Kai Wassermann:

ich habe nach einem "apt-get dist-upgrade" kein X11 mehr. Das könnte ich
wohl lösen, möchte aber zuerst verstehen, warum das passiert ist.



Kann es sein, dass Du fà¼r Deinen nVidia-Chip den Legacy-Treiber
benötigst? Dieser ist aber imho nicht mehr kompatibel zu dem
installierten Kernel 4.4.6 aus den Backports bei Dir.
Wahrscheinlich wurde daher vom Paketmanagement der neuere Treiber aus
den Backports nachgezogen, um diese Abhà¤ngigkeit/Konflikt aufzulösen.

Zusà¤tzliche Infos liefere ich gerne nach.



Welcher nVidia-Chip steckt denn da genau drin?


MfG Richi




Ähnliche fragen