Versteckte Zeichen in Dateinamen mit ls

10/08/2016 - 12:20 von Christian Knoke | Report spam
Moin.

Dies ist etwas merkwürdig, deshalb wollte ich es euch mal zeigen.

chris@leo:/media/int3/DATEN$ ls -l
insgesamt 95224
drwx 2 chris chris 4096 Jul 17 14:33 ARCHOS
drwxr-xr-x 2 chris chris 4096 Jul 17 14:42 archos101
drwx 2 chris chris 4096 Jul 17 14:36 ARCHOS_FAQ_-_About_ARCHOS_28,_32,_35,_43,_70,_101_internet_tablets
-rw-r--r-- 1 chris chris 66788 Jul 17 14:36 ARCHOS_FAQ_-_About_ARCHOS_28,_32,_35,_43,_70,_101_internet_tablets.html
-rw-r--r-- 1 chris chris 16080 Jul 17 14:33 ARCHOS.html
-rw-r--r-- 1 chris chris 17705 Jul 17 14:33 changes_firmware_archos_android_gen8.htm
-rw-r--r-- 1 chris chris 31797 Jul 17 14:31 Declaration_of_conformity_a101it_en.pdf
[...]

Wenn ich es allerdings vom Bildschirm abkopiere, dann sieht es so aus:

chris@leo:/media/int3/DATEN$ ls -l
insgesamt 95224
drwx 2 chris chris 4096 Jul 17 14:33 <202A>ARCHOS
drwxr-xr-x 2 chris chris 4096 Jul 17 14:42 archos101
drwx 2 chris chris 4096 Jul 17 14:36 <202A>ARCHOS_FAQ_-_About_ARCHOS_28,_32,_35,_43,_70,_101_internet_tablets
-rw-r--r-- 1 chris chris 66788 Jul 17 14:36 <202A>ARCHOS_FAQ_-_About_ARCHOS_28,_32,_35,_43,_70,_101_internet_tablets.html
-rw-r--r-- 1 chris chris 16080 Jul 17 14:33 <202A>ARCHOS.html
-rw-r--r-- 1 chris chris 17705 Jul 17 14:33 changes_firmware_archos_android_gen8.htm
-rw-r--r-- 1 chris chris 31797 Jul 17 14:31 Declaration_of_conformity_a101it_en.pdf

allerdings nur, wenn ich es in den joe hineinkopiere, im mousepad sieht man
nichts. joe kennzeichnet mit der (unterstrichenen) Zeichenfolge <202A>
offenbar ein Sonderzeichen, dass sich vor dem Namen befindet.

Letztlich bemerkt habe ich dies dadurch, dass die Dateinamen mit ls -l *
zwar gelistet wurden, ls -l ARCHOS jedoch nicht funktionierte:
$ ls: Zugriff auf ARCHOS nicht möglich: Datei oder Verzeichnis nicht gefunden

Welches Zeichen das ist, und wie es dort hineinkommt, weiss ich allerdings
nicht. Ich erinnere mich jetzt aber mit dem Ordner schon früher mal
Schwierigkeiten gehabt zu haben - unter Gnome.

Thunar 1.6.3 bemerkt von alledem nichts und öffnet den Ordner "ARCHOS"
problemlos.

Gruß
Christian

Christian Knoke * * * http://cknoke.de
* * * * * * * * * Ceterum censeo Microsoft esse dividendum.
 

Lesen sie die antworten

#1 Dirk Griesbach
10/08/2016 - 13:00 | Warnen spam
Am Mi, 10. Aug 2016 um 12:09:51 +0200 schrieb Christian Knoke:
allerdings nur, wenn ich es in den joe hineinkopiere, im mousepad sieht man
nichts. joe kennzeichnet mit der (unterstrichenen) Zeichenfolge <202A>
offenbar ein Sonderzeichen, dass sich vor dem Namen befindet.



Das ist eines von mehreren möglichen Unicode Zeichen, um die
Schreibrichtung des Textes anzugeben – in dem Fall links nach rechts.
Selbst werden diese Zeichen im Text aber nicht angezeigt. Vermutung: Du
hast mal in 'nem Webbrowser diese ARCHOS-FAQ lokal gespeichert und der
Browser hat den Dateinamen aus der Webseite übernommen, in der das so
angegeben war.

Gruß
Dirk

Ähnliche fragen