Verteilung eines Betrags auf verschieden Spalten

05/03/2009 - 23:58 von a | Report spam
Guten Abend Newsgroup,

ich habe folgendes Anliegen. Für eine dynamische Abschreibungstabelle
würde ich gern einen Betrag (sagen wir 100) in Abhàngigkeit der
Abschreibungsdauer verteilen. Bspw sollte bei einer Dauer von 4 Jahren
vier Spalten mit jeweils 25 gefüllt werden. Sofern man die Dauer auf 3
Jahre verkürzt, sollen es noch 3 Spalten mit jeweils 33,3 sein. Wird der
Zeitraum verlàngert, werden jeweils mehr Spalten gefüllt.

Meine bisherige (umstàndliche) Lösung sieht in etwa so aus:
C3 = Betrag
C2 = Dauer

In C7 steht C3/C2, in der Annahme das immer mindesten 1 Jahr
abgeschrieben wird.

C8: =+WENN(SUMME($C$7:C7)-$C$3=0,0,$C$3/$C$2)

Diese Formel "ziehe" ich dann nach rechts. Im Ergebnis funktioniert es,
aber handlich ist es nicht.

Wenn jemand eine elegantere Lösung hàtte (vielleicht über eine
Array-Formel) bzw. einen Tipp für Gockel, dann wàre ich dankbar.

Einen schönen Abend noch.

Simon
 

Lesen sie die antworten

#1 Thomas Ramel
06/03/2009 - 06:29 | Warnen spam
Grüezi Simon

a schrieb am 05.03.2009

ich habe folgendes Anliegen. Für eine dynamische Abschreibungstabelle
würde ich gern einen Betrag (sagen wir 100) in Abhàngigkeit der
Abschreibungsdauer verteilen. Bspw sollte bei einer Dauer von 4 Jahren
vier Spalten mit jeweils 25 gefüllt werden. Sofern man die Dauer auf 3
Jahre verkürzt, sollen es noch 3 Spalten mit jeweils 33,3 sein. Wird der
Zeitraum verlàngert, werden jeweils mehr Spalten gefüllt.



Wie gross ist denn der maximale Zeitraum, den Du planst?

Meine bisherige (umstàndliche) Lösung sieht in etwa so aus:
C3 = Betrag
C2 = Dauer

In C7 steht C3/C2, in der Annahme das immer mindesten 1 Jahr
abgeschrieben wird.

C8: =+WENN(SUMME($C$7:C7)-$C$3=0,0,$C$3/$C$2)

Diese Formel "ziehe" ich dann nach rechts. Im Ergebnis funktioniert es,
aber handlich ist es nicht.



Hmmm, das Ganze schaut bereits recht fertig aus - Du könntest allenfalls
noch leicht verkürzen auf:

=SUMME($C$7:C7<=$C$3)*($C$3/$C$4)

und das Ganze nach *unten* ziehen

Wenn jemand eine elegantere Lösung hàtte (vielleicht über eine
Array-Formel) bzw. einen Tipp für Gockel, dann wàre ich dankbar.



Was genau stellst Du dir 'eleganter' vor?
Du musst die Zellen mit Formeln vorbelegen und ob das nun eine Matrixformel
ist oder etwas anderes spielt keine grosse Rolle.


Mit freundlichen Grüssen
Thomas Ramel

- MVP für Microsoft-Excel -
[Vista Ultimate SP-1 / xl2007 SP-1]

Ähnliche fragen