Verweis auf ext. Tabelle mit variablen Dateinamen

25/02/2010 - 10:29 von S.Bockelmann | Report spam
Hallo,

mit der Formel

=SUMME('C:\Documents and Settings\user\My
Documents\Berechnung\Kalkulation_All\2010-01-31_Country\[2010-01-31_Country_AT.XLS]Company_AT_1'!$G$5:$G$500)

kann ich in einer Exceltabelle(A) die Summe der Spalte G5-G500 einer
anderen, nicht zwingend geöffneten Tabelle(B) erstellen. Das funktioniert
soweit.

Nun möchte ich aber gerne bestimmte Elemente der Formel durch Feldinhalte
meiner Tabelle(A) ersetzen, z.B. 2010-01-31 durch den Inhalt der Zelle A3 ,in
der z.B. '2010-02-28' steht und den Text 'AT' durch den Inhalt einer anderen
Zelle (z.b. A5), in der 'DE' steht.

Hintergrund: es gibt für jeden Monat ein Vezeichnis, in dem sich Tabellen
aus versch. Làndern mit unterschiedlichen Daten, aber mit derselben Struktur
befinden.
In meiner Tabelle(A) sollen diese Làndertabellen konsolidiert werden.
Kriegen wir das hin?

Besten Dank
S.Bockelmann
 

Lesen sie die antworten

#1 Alexander Wolff
25/02/2010 - 10:51 | Warnen spam
Google nach INDIRECT.EXT, Pull-Function, Harlan Grove

http://groups.google.com/group/micr...53560f0075

http://erlandsendata.no/?p!06 ist auch eine Möglichkeit

Hintergrund: =INDIREKT(), die Funktion, die Du gerne verwenden würdest, kann
dies nur bezüglich geöffneter Arbeitsmappen.
Moin+Gruss Alexander - MVP for MS Excel - www.xxcl.de - mso2000sp3 --7-2

Ähnliche fragen