Verweis oder Index

25/06/2010 - 11:31 von Gerhard Reil | Report spam
Hallo NG,

ich "schlage" mich mit einem Problem herum, zu dem ich momentan keine
Lösung finde; bestimmt kann mir geholfen werden!

Ich möchte eine Blutdrucktabelle erstellen, wonach bei dem Eintrag des
jeweiligen Wertes - getrennt nach oberer und unterer Wert - in einer
separaten Spalte der Text aus einer Aufstellung ausgegeben wird.

Die Basistabelle sieht son aus:


Einteilung oberer wert unterer Wert
MIN MAX MIN MAX
Optimal 100 120 50 80
Normal 121 130 81 85
usw.

nun soll EXCEL bei dem eingetragenen Wert z.B. 123 / 83
jeweils die Einteilung "Optimal" oder "Normal" ausgeben.

Wie kann ich dieses Problem lösen?

Danke im Voraus.

Gerhard
WIN XP
EXCEL 2003
 

Lesen sie die antworten

#1 Dietmar Vollmeier
25/06/2010 - 15:37 | Warnen spam
Schönen Nachmittag, Gerhard!

*Gerhard Reil* schrieb am 25.06.2010 um 11:31 Uhr...
Die Basistabelle sieht son aus:



Gehen wir mal davon aus, daß diese Tabelle im Tabellenblatt "Tabelle1",
ab Zelle A1 so drinnen steht

+--++-+--+--+--+
Š Š A Š B Š C Š D Š E Š
+--++-+--+--+--+
Š 1 Š Einteilung Š oberer Wert Š unterer Wert Š
+--++-+--+--+--+
Š 2 Š Š MIN Š MAX Š MIN Š MAX Š
+--++-+--+--+--+
Š 3 Š Optimal Š 100 Š 120 Š 50 Š 80 Š
+--++-+--+--+--+
Š 4 Š Normal Š 121 Š 130 Š 81 Š 85 Š
+--++-+--+--+--+

nun soll EXCEL bei dem eingetragenen Wert z.B. 123 / 83
jeweils die Einteilung "Optimal" oder "Normal" ausgeben.



Hierzu schaut meine Eingabe/Abfrage in einem extra Tabellenblatt so aus:

+--++-+-+
Š Š A Š B Š C Š
+--++-+-+
Š 1 Š oben Š unten Š Status Š
+--++-+-+
Š 2 Š 123 Š 83 Š Normal Š
+--++-+-+

Wie kann ich dieses Problem lösen?



Schreibe in C2 folgende Formel und kopiere diese anschließend soweit wie
gewünscht nach unten

=WENN(ANZAHL(A2:B2)<2;"";BEREICH.VERSCHIEBEN(Tabelle1!A$2;SUMMENPRODUKT((A2>=Tabelle1!B$3:B$4)*(A2<=Tabelle1!C$3:C$4)*(B2>=Tabelle1!D$3:D$4)*(B2<=Tabelle1!E$3:E$4)*ZEILE($1:$2));))

Danke im Voraus.



HTH
Servus | Die Meteorologen haben endlich den Sommer entdeckt! - Er
Didi | hatte sich im Kühlschrank versteckt...

Ähnliche fragen