Verweis oder...

17/10/2012 - 23:38 von Hans Alborg | Report spam
Hi,

jetzt hab ich soviel VBA't daß ich keine Excel- Formeln mehr hinbekomme!

Excel 2007...
In einer Spalte sind eine Reihe Zeiten [h]mm enthalten, und darunter die
Summe, ebenso formatiert.
Bedingungen:
- Zeiten >15:00 werden nicht gezàhlt
- leere Zellen sind leer (nicht "0:00")

Das geht mit dieser Formel in der Summenzelle:

=WENN(SUMMEWENN(O18:O32;"<15:00")=0;"";SUMMEWENN(O18:O32;"<15:00"))

jetzt kommt aber mein Problem dazu:

In Spalte A (gleiche Zeile) steht Text, und bei einem Bestimmten ("Abzug")
soll die Zeit in derselben Zeile nicht in die Summe einfließen; aber
trotzdem in der Zelle stehen wie die anderen Zeiten in den Zeilen 18...32
auch.

Verweis geht hier nicht weil A links (vor O) kommt, oder?

Hans
 

Lesen sie die antworten

#1 Detlef Lewin
18/10/2012 - 00:30 | Warnen spam
Am 17.10.2012 23:38, schrieb Hans Alborg:

Hallo Hans

Wenn ich das richtig verstanden habe (ohne die Fehlerabfrage):
=SUMMEWENNS(O18:O32;O18:O32;"<15:00";A18:A32;"<>Abzug")

Ähnliche fragen