virtualenv legt keine virtuelle Umgebung an – Fehlermeldungen

09/08/2012 - 14:47 von Suesssauer | Report spam
Hallo zusammen,

ich benötige zur Arbeit "virtualenv". Es làsst sich auch installieren (die Installation erfolgt ohne Fehler),
und das benötigte Verzeichnis wird angelegt. Ansonsten gibt es nur noch Fehlermeldungen, also es funktioniert nicht.

Kennt sich einer aus, oder kann mir sagen, wie ich weiterkomme?
Hilfreiche Console-Ausgaben unten, meine Kommentare/Einschübe in ">>".

Vielen Dank!!
Suesssauer

->

Initial meine Konfig: MacOS 10.6.8 (Snow Leopard), Python 2.7.

1) Anlegen der virtualenv:

Suesssauer:site-packages sss$ virtualenv --distribute /Users/sss/EclipseProjects/django-projects/DEV
New python executable in /Users/sss/EclipseProjects/django-projects/DEV/bin/python
Please make sure you remove any previous custom paths from your /Users/sss/.pydistutils.cfg file.



fyi – Inhalt von .pydistutils.cfg:
install_lib = /Library/Python/$py_version_short/site-packages






Installing distributedone.
Installing pip
Complete output from command /Users/sss/Ecli...DEV/bin/python -x /Users/sss/Ecli...VEL/bin/easy_install /Library/Python/2.7/...pport/pip-1.1.tar.gz:
/Users/sss/EclipseProjects/django-projects/DEV/bin/python: can't open file '/Users/sss/EclipseProjects/django-projects/DEV/bin/easy_install': [Errno 2] No such file or directory



ja, fehlt. Aber kann ja nicht sein, dass ich das da hinkopieren soll ?





-
...Installing pip...done.
Traceback (most recent call last):
File "/Library/Frameworks/Python.framework/Versions/2.7/bin/virtualenv", line 8, in <module>
load_entry_point('virtualenv==1.7.2', 'console_scripts', 'virtualenv')()
File "/Library/Python/2.7/site-packages/virtualenv.py", line 942, in main
never_download=options.never_download)
File "/Library/Python/2.7/site-packages/virtualenv.py", line 1054, in create_environment
install_pip(py_executable, search_dirs=search_dirs, never_download=never_download)
File "/Library/Python/2.7/site-packages/virtualenv.py", line 654, in install_pip
filter_stdout=_filter_setup)
File "/Library/Python/2.7/site-packages/virtualenv.py", line 1020, in call_subprocess
% (cmd_desc, proc.returncode))
OSError: Command /Users/sss/Ecli...ork_DEVEL/bin/python -x /Users/sss/Ecli...VEL/bin/easy_install /Library/Python/2.7/...pport/pip-1.1.tar.gz failed with error code 2



Keine Ahnung. Das File "/Library/Python/2.7/site-packages/virtualenv_support/pip-1.1.tar.gz" existiert jedenfalls!






2) Kontrolle: Installation von virtualenv – muss man die Warnings berücksichtigen?

Hier die Ausgaben:Suesssauer:site-packages sss$ pip install virtualenv
Downloading/unpacking virtualenv
Downloading virtualenv-1.7.2.tar.gz (2.2Mb): 2.2Mb downloaded
Running setup.py egg_info for package virtualenv

warning: no previously-included files matching '*' found under directory 'docs/_templates'
warning: no previously-included files matching '*' found under directory 'docs/_build'
Installing collected packages: virtualenv
Running setup.py install for virtualenv

warning: no previously-included files matching '*' found under directory 'docs/_templates'
warning: no previously-included files matching '*' found under directory 'docs/_build'
Installing virtualenv script to /Library/Frameworks/Python.framework/Versions/2.7/bin
Installing virtualenv-2.7 script to /Library/Frameworks/Python.framework/Versions/2.7/bin
Successfully installed virtualenv
Cleaning up...
 

Lesen sie die antworten

#1 Christopher Arndt
09/08/2012 - 19:16 | Warnen spam
This is an OpenPGP/MIME signed message (RFC 2440 and 3156)

On 09.08.2012 14:47, Suesssauer wrote:
1) Anlegen der virtualenv:

Suesssauer:site-packages sss$ virtualenv --distribute /Users/sss/EclipseProjects/django-projects/DEV
New python executable in /Users/sss/EclipseProjects/django-projects/DEV/bin/python
Please make sure you remove any previous custom paths from your /Users/sss/.pydistutils.cfg file.

fyi – Inhalt von .pydistutils.cfg:
install_lib = /Library/Python/$py_version_short/site-packages







Wie die Meldung schon sagt, mach mal (den Inhalt von) ~/.pydistutils.cfg
weg.

Dann installiere am besten auch virtualenv noch mal nue und mit "sudo".
Und führe die Befehle mit deinem Homedirectory als Working directory
aus, nicht in irgendeinem "site-packages" directory.


Chris




Ähnliche fragen