VLOOKUP-SUMPRODUCT Formel?

12/12/2007 - 14:05 von Mike | Report spam
Hallo,

ich habe folgende Datenbank:

Rating Market Value
BBB 10
A 20
AA 30
AAA 50
A 10
BBB 30
AA 20
Total 170

und folgende Mapping-Tabelle:

Rating Score
AAA 19
AA 18
A 17
BBB 16

Ich möchte EINE FORMEL in EINER ZELLE haben, die folgendes macht:
- geht alle Eintràge in der Datenbank durch
- sucht in der Mapping-Tabelle das Score
- multipliziert das Score mit dem Anteil der Position an dem Gesamt Market
Value und summiert dieses Produkt über alle Eintràge auf

So sieht die Berechnung manuell aus:

Rating Market Value %MV Score Wght Avg Score
BBB 10 5,88% 16 0,94
A 20 11,76% 17 2,00
AA 30 17,65% 18 3,18
AAA 50 29,41% 19 5,59
A 10 5,88% 17 1,00
BBB 30 17,65% 16 2,82
AA 20 11,76% 18 2,12
Total 170 100,00% 17,65

Die Formel sollte also in diesem Fall die 17,65 als Ergebnis ausgeben.

Ich habe schon alles ausprobiert und bin für jeden Rat dankbar!

Gruß

Mike
 

Lesen sie die antworten

#1 Alexander Wolff
12/12/2007 - 16:18 | Warnen spam
{=SUMME((A1:A7=MTRANS(A9:A12))*B1:B7*MTRANS(B9:B12))/SUMME(B1:B7)}
Moin+Gruss Alexander - MVP for MS Excel - www.xxcl.de - mso2000sp3 --7-2

Ähnliche fragen