Forums Neueste Beiträge
 

Vorkommen prüfen

22/07/2008 - 15:40 von Boris Kirkorowicz | Report spam
Hallo,
ich habe hier eine Tabelle, in der in Spalte A Namen mit Zusàtzen stehen
und in Spalte H Namen ohne Zusàtze. Nun möchte ich ermitteln, welche
Namen in Spalte H sich in Spalte A wiederfinden. Bislang habe ich dafür
die Funktion

=SVERWEIS(H2;A$2:A$500;1;FALSCH)

gefunden, die aber nur genaue Übereinstimmungen erfasst. Die Funktion

=SVERWEIS(H2;A$2:A$500;1;WAHR)

hingegen ist zu ungenau, denn sie liefert auch dann einen Wert zurück,
wenn nur ein einziges Zeichen (oder noch nicht einmal das) gefunden
wird. Wie erreiche ich das Gewünschte?


Gruß Greetings
Boris Kirkorowicz

Falls Ihre E-Mail versehentlich im Spamfilter haengengeblieben zu sein
scheint, bitte das Formular unter http://www.kirk.de/mail.shtml nutzen.
If your eMail seems to be caught by the SPAM filter by mistake, please
use the form at http://www.kirk.de/mail.shtml to drop me a note.
 

Lesen sie die antworten

#1 Claus Busch
22/07/2008 - 15:52 | Warnen spam
Hallo Boris,

Am Tue, 22 Jul 2008 15:40:23 +0200 schrieb Boris Kirkorowicz:

ich habe hier eine Tabelle, in der in Spalte A Namen mit Zusàtzen stehen
und in Spalte H Namen ohne Zusàtze. Nun möchte ich ermitteln, welche
Namen in Spalte H sich in Spalte A wiederfinden. Bislang habe ich dafür
die Funktion

=SVERWEIS(H2;A$2:A$500;1;FALSCH)

gefunden, die aber nur genaue Übereinstimmungen erfasst. Die Funktion

=SVERWEIS(H2;A$2:A$500;1;WAHR)

hingegen ist zu ungenau, denn sie liefert auch dann einen Wert zurück,
wenn nur ein einziges Zeichen (oder noch nicht einmal das) gefunden
wird. Wie erreiche ich das Gewünschte?



probiers mal so für die Anzahl der Übereinstimmungen:
=ZÄHLENWENN($A$2:$A$500;H2&"*")
oder so, um Wahr oder Falsch zu erhalten:
=ZÄHLENWENN($A$2:$A$500;H2&"*")>0


Mit freundlichen Grüssen
Claus Busch
Win XP Prof SP2 / Vista Ultimate
Office 2003 SP2 / 2007 Ultimate

Ähnliche fragen