VPN bricht nach 50 Minuten ab (Cisco)

23/10/2007 - 00:26 von Marcos Zattar | Report spam
Hallo,

nach Stunden Recherchen in Webseiten und rumprobieren mit MTU-Werten ohne
Erfolg wende ich mich an die NG. Ich benutze VPN, um mich mit dem Server
meiner Firma zu verbinden und um von zu Hause aus zu arbeiten. Die
Verbindung klappt prima, aber dann bricht sie nach 50 Minuten ab und meine
ganze
Arbeit geht einfach verloren.

In diversen Foren und selbst in der offiziellen Microsoft-Support-Portal
habe ich gelesen, dass die Paketgrößen vielleicht zu groß sind (MTU-Werte).
Ich habe die ideale MTU-Werte anhand des Tools MTU-Route
(http://www.elifulkerson.com/project...oute.phpin) gemessen und
dementsprechend in der Registry geàndert.

Das Ergebnis des Tools war:

C:\test\mturoute.exe <NameMeinesServers>.dyndns.org

* ICMP Fragmentation is not permitted. *
* Maximum payload is 10000 bytes. *
- ICMP payload of 5046 bytes failed..
- ICMP payload of 2569 bytes failed..
- ICMP payload of 1330 bytes failed..
+ ICMP payload of 711 bytes succeded..
- ICMP payload of 1020 bytes failed..
+ ICMP payload of 865 bytes succeed..
- ICMP payload of 942 bytes failed..
+ ICMP payload of 903 bytes succeeded.
- ICMP payload of 922 bytes failed..
+ ICMP payload of 912 bytes succeded.
- ICMP payload of 917 bytes failed..
+ ICMP payload of 914 bytes succeeded.
- ICMP payload of 915 bytes failed..
+ ICMP payload of 914 bytes succeeded.
- ICMP payload of 914 bytes failed..
Path MTU: 942 bytes.


Im
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\NdisWan\Parameters\Protocols\0\

sind jetzt die folgenden Schlüssel:

(Standard) - REG_SZ - (Wert nicht gesetzt)
PPPProtocolType - REG_DWORD - 0x00000021 (33)
ProtocolMTU - REG_DWORD - 0x00000514 (1300)
ProtocolType - REG_DWORD - 0x00000800 (2048)
TunnelMTU - REG_DWORD - 0x00000390 (912)

Nach den Anweisungen in dieser Webseite
http://johanpersson.nu/DasBlog/Perm...f28fb.aspx
habe ich dann den Schlüssel TunnelMTU auf 912 geàndert, da dieser der
zulàssige Maximalwert laut des Tools ist.
(Vor meiner Registry-Änderung sahen die Schlüssel und entsprechende Werte
genauso aus, mit Ausnahme des Schlüssels TunnelMTU, den ich selbst eingefügt
habe.)

Was die Stabilitàt der VPN-Verbindung angeht hat sich nichts geàndert: sie
bricht nach 50 bis 60 Minuten ab, manchmal sogar früher.

Unter meinen Kollegen, die auch ein Home-Office haben, gab es
unterschiedliche Erfahrungen. Diejenigen, die einen ADSL-Anschluß bei
anderen Providern als Telekom/T-Online, hatten Probleme. Nachdem ein oder 2
Kollegen auf Telekom/T-Online umgestiegen sind, ist die VPN-Verbindung viel
stabiler geworden. Mein Problem ist aber: ich bin *immer* bei
Telekom/T-Online gewesen.

*Zu meinem System*

Dell Dimension 3,0 Ghz + 1 Gb RAM
Internetanschluß von T-Online: flat 3000 kbits/s
Router: Eumex 300 IP von T-Com
Betriebssystem: Windows XP Pro mit SP2

*VPN Client*

Cisco Systems VPN Client Version 4.8.01.0300
Client type: Windows, WinNt
Group Authentication
(Kein Certificate Authentication nötig/Kein Mutual Group Authentication)
Transport: IPSec over UDP ( NAT / PAT )
Keine Backup Servers
Dial-Up: keine besondere Einstellungen
Log Settings: bei allen Level 3


Die obige Konfiguration des VPN-Clients wurde mir vom meiner Firma
empfohlen, genauso wie das Folgende:

"Die Ports IP 50 und UDP 500 müssen freigeschaltet sein bei dem Router". Und
so habe ich diese Konfiguration im Router gemacht, was auch nichts gebracht
hat:

Im Bereich "Netwerk -> NAT & Portregeln" des Eumex habe ich die folgende
Regel hinzugefügt:

Aktivierter Port: Protokoll - UDP
Port - 500

Computer/Server im lokalen Netzwerk: IP-Adresse 192.168.178.20
Port 50




Ich wüsste nicht, was ich sonst machen könnte! Ich wàre sehr dankbar, wenn
jemand mir einen erleuchtenden Tipp hàtte!


Gruß
Marcos Zattar
 

Lesen sie die antworten

#1 Juergen Kluth
23/10/2007 - 07:57 | Warnen spam
hi
http://www.cisco.com/en/US/products...2dbe.shtml
nach disconnect suchen
g jk

Ähnliche fragen