Forums Neueste Beiträge
 

vpn für Cisco von Shrew

10/03/2010 - 12:41 von Albrecht Mehl | Report spam
Unter 11.2, kde 4.3.5 soll der vpnclient von Shrew und nicht der von
opensuse mitgelieferte installiert werden, weil es für Shrew bereits ein
vorgefertigtes Profil zu meinem Zielsystem gibt. Auf der Seite

/home/am/internet/shrewvpn/ike/README.TXT

sind die Voraussetzungen angegeben:

XXXXXXXXXXXXXXXXXXXXXXX

REQUIREMENTS
=
This section describes the basic requirements used to compile this
software. In
most cases, development versions of the dependencies will need to be
installed.
These could be available as pre-compiled packages or compiled directly from
source.

Minimum

c++ compiler
stock c libs
stock c includes
pthread support

lex or flex
bison >= 2.3
cmake >= 2.4
opsenssl >= 0.9.x

This software requires Bison version 2.3 or higher as it uses the new c++
parser model. The c++ model was introduced in version 2.1 but appears to be
incomplete.

Optional

TrollTech QT >= 3.3 ( multithreaded version, qt-mt )
openldap >= 2.0

The Trolltech QT toolkit version 3.3.x or higher is also required if you
plan
to build the QT client front end applications. Version 4.x has not been
tested
and is not supported. The openldap support is only required if you plan
to use
iked to facilitate VPN client gateway connectivity and require xauth support
via an external LDAP database.

XXXXXXXXXXXXXXXXXXXXXXXXXX

Dazu Fragen:

1. yast zeigt mir zwar etwas für 'c lib', nicht aber für 'c include' an.
Woher bekomme ich die benötigten Pakete?
2. Was ist pthread support?
3. opsenssl habe ich weder in yast noch in rpmseek gefunden. Woher also
nehmen?

A. Mehl
Albrecht Mehl |
Schorlemmerstr. 33 |Tel. (06151) 37 39 92
D-64291 Darmstadt, Germany|sehenswert - ungefàhr 'Wir einsam im All'
http://www.phrenopolis.com/perspect...index.html
 

Lesen sie die antworten

#1 Ansgar Strickerschmidt
10/03/2010 - 13:22 | Warnen spam
Also schrieb Albrecht Mehl:

Dazu Fragen:

1. yast zeigt mir zwar etwas für 'c lib', nicht aber für 'c include' an.
Woher bekomme ich die benötigten Pakete?



Die Includes dürften die Header-Files zu den Libraries und zum
C/C++-Compiler sein. Mithin also die *-devel-Pakete, die zu den Libraries
und zum Compiler gehören.

2. Was ist pthread support?



Da bin ich kein Experte, aber AFAIK bedutet das die Unterstützung von
POSIX-konformen Threads, also eine bestimmte art des
Multitaskings/Multithreadings. Da können Dir andere mehr sagen.

3. opsenssl habe ich weder in yast noch in rpmseek gefunden. Woher also
nehmen?



Fipptehler. :) Da ist ein s zuviel. Mit "openssl" wirst Du fündig.

Ansgar

*** Musik! ***

Ähnliche fragen