VPN Problem Tunnelblick

24/11/2010 - 15:22 von Ingo Lembcke | Report spam
Hallo!
Ich habe hier ein hübsches Problem mit VPN (über strongvpn.com) und
OpenVPN mit Tunnelblick.

Wenn ich bei aktiviertem VPN myspace.com aufrufe, lande ich bei Google.com.

Alle Browser. Wenn VPN aktiv ist, kann ich auch die 2 IP-Adressen, die ich
für myspace.com rausgefunden habe, eingeben im Browser und lande bei Google.
IP1: 216.178.39.11, IP2: 63.135.80.46

Das Problem über Google gesucht, gibt es diverse Fundstellen zu gehackten
DSL-Router-Problemen. Das ist es hier nicht.
Ich tippe auf ein DNS-Problem tippen, aber Wechsel der DNS und Analyse im
Terminal hat nicht geholfen.

Ich habe noch massig an Infos, aber die sehen mir alle nicht danach aus, als
wenn sie weiterhelfen. Hier sind sie trotzdem (waren mir für die Newsgroup
zu lang):
<http://ile.dyndns.tv/ile/Hilfe/Safa...ct.txt>
Andere Info s.u. und kann ich auf Anforderung nachliefern, sei es hier oder
auf dem Server.

Was wirklich unterschiedlich ist, in Safari Entwickler-Menü Fehlerkonsole
einblenden, Ressourcenprotokoll starten zeigt bei VPN auf das GET einen
Status-Code: 302 (Umleitung) an.
Ohne VPN wird ein Status-Code: 200 (OK) angezeigt.
Dann funktioniert myspace.com.

Router: Fritz!Box 7390 an VDSL bei T-Online, bekommt DNS automatisch
zugewiesen. Im lokalen Netz kein DHCP, sondern feste Adressen.
DNS ausprobiert:
1. Einstellung 192.168.1.99, 216.131.95.20, 216.131.94.5
2. Einstellung 8.8.8.8, 8.8.8.4, 208.67.222.222, 208.67.220,220
192.168.1..99 ist der Router
216.* sind die DNS von Reliable Hosting / strongvpn
8.* sind die Google-DNS
208.* sind die OpenDNS
Wobei der Aufruf von myspace.com ohne VPN problemlos mit allen DNS
funktioniert.

OpenVPN nimmt die in Mac OS X eingestellten DNS. Wenn dort keine
eingestellt sind, werden die DNS von strongvpn / reliablehosting gepusht
und funktionieren bis auf myspace. Deshalb war meine normale Konfiguration,
das ich der Einfachheit halber, diese DNS auch in der Mac OS X-Konfiguration
zusàtzlich zum Router eingetragen habe ( also oben 1. )

Bei Tunnelblick online habe ich nicht passendes gefunden, ausser das es
ein Snow Leopard-Problem mit DNS gibt, aber die Beschreibung liest sich
nach einem anderen Problem (m.E.).

Ich kann auch gerne mehr Infos liefern.
Wenn ich in den nàchsten Tagen nichts rausfinde bzw. ihr mir nicht helfen
könnte, werde ich eine Supportanfrage bei strongvpn machen, aber
im Moment glaube ich nicht, das das Problem von deren Seite kommt.
Prioritàt ist bei mir ausserdem gering, da ich ja eine Lösung habe, VPN
abschalten, auch wenn es unpraktisch ist.
Ich möchte aber gerne die Ursache und möglichst eine Lösung erfahren, um
zu verstehen, wie das passiert.

Danke...

Mfg,
Ingo Lembcke
Und eine deutsche Fehlermeldung
("Pfeife zerbrochen" oder àhnliches) ist so richtig, richtig kontraproduktiv :-( aus de.comp.sys.mac.misc von Christian Kirsch
 

Lesen sie die antworten

#1 schlu-do
24/11/2010 - 15:48 | Warnen spam
Ingo Lembcke schrieb:

Ich habe noch massig an Infos, aber die sehen mir alle nicht danach aus, als
wenn sie weiterhelfen. Hier sind sie trotzdem (waren mir für die Newsgroup
zu lang):
<http://ile.dyndns.tv/ile/Hilfe/Safa...ct.txt>



Da hast du die MySpace-Seite auf dem VPN-Rechner via https aufgerufen.
Gibt es ohne SSL die gleichen Probleme? Ansonsten kann man da sehen,
dass die Antwort anscheinend vom MySpace-Webserver kommt (oder zumindest
von einem, der àhnliche Headerzeilen schickt). Nur dass der Webserver
eben nicht die Seite ausliefert, sondern über den "Location"-Header zu
Google weiterleitet.

Was wirklich unterschiedlich ist, in Safari Entwickler-Menü Fehlerkonsole
einblenden, Ressourcenprotokoll starten zeigt bei VPN auf das GET einen
Status-Code: 302 (Umleitung) an.



Genau. Und eben einen Location-Header, der dich zu Google weiterschickt.
Hast du irgendwelche Proxies eingetragen (oder macht der VPN-Anbieter
sowas)?

OpenVPN nimmt die in Mac OS X eingestellten DNS. Wenn dort keine
eingestellt sind, werden die DNS von strongvpn / reliablehosting gepusht
und funktionieren bis auf myspace. Deshalb war meine normale
Konfiguration, das ich der Einfachheit halber, diese DNS auch in der Mac
OS X-Konfiguration zusàtzlich zum Router eingetragen habe ( also oben 1. )



Naja, bisher sieht das ja nicht unbedingt nach einem DNS-Problem aus. Du
musst halt herausfinden, wie der "Location"-Header in die Antwort des
Webservers kommt. Und warum jemand das macht bzw. wie du das abstellen
kannst ... .


Gruß,

Dominik.

Ähnliche fragen