VPN Server Problem

20/08/2013 - 18:39 von wg | Report spam
Hi Leute,

ich betreibe einen privaten Internetserver der u.A. auch VPN-Dienste
anbieten soll.
Derzeit làuft VPN via pptpd, da (vorerst) die Windows-VPN-Clients
verwendet werden.


Folgendes Problem:

Die Windowsrechner PC1 ud PC2 sind im selben LAN.
Der LAN Gatewayrechner (POSTROUTING SNAT) ist eine openSUSE-11.3.
Das Pakethandling/Filtern erfolgt nicht mit SuSERfirewall2 sondern mit einem
'selbstgebackenen' Scrip.

PC1 und PC2 gehen über den Gatewayrechner ins Internet, das geht problemlos.


Nun das VPN Problem:

Rechner PC1 (192.168.1.20) öffnet erfolgreich eine VPN-Verbindung mit
WAN-VPN-SERVER.

Rechner PC2 (192.168.1.99) will ebenfalls eine VPN-Verbindung mit
WAN-VPN-SERVER öffen.

Die Aktion endet jedoch mit Fehler 619: es kann keine Verbindung
hergestellt werden.

Mit WireShark über das Interne Interface sehe ich, daß das
VPN-Handshaking immer
über den zuerst aktiven VPN-PC làuft.

Nach einem Restart des Gatewayrechners klapp die VPN-Verbindung mit PC2.
Es liegt also offensichtlich am Gatewayrechner...


Kann mir jemand einen Tipp geben was das falsch làuft?

Ein Beispiel fürs Routing und/oder Pakethandling wàre sehr hilfreich.


Danke
Wolf
 

Lesen sie die antworten

#1 Tim Ritberg
20/08/2013 - 19:32 | Warnen spam
Am 20.08.2013 18:39, schrieb wg:

Nach einem Restart des Gatewayrechners klapp die VPN-Verbindung mit PC2.
Es liegt also offensichtlich am Gatewayrechner...


Kann mir jemand einen Tipp geben was das falsch làuft?

Ein Beispiel fürs Routing und/oder Pakethandling wàre sehr hilfreich.



Dann lies doch einfach die Anleitung. Da steht nàmlich auch welche
IP-Protokolle man routen muss.

BTW PPTP ist total outdated. OpenVPN gibts auch für Windows


Tim

Ähnliche fragen