VS Extensions WSS auf Windows XP

20/09/2007 - 16:24 von Mirco Kaffsach | Report spam
Hallo zusammen,

ich habe da ein Problem, oder einfach nur ein Brett vorm Kopf.

Ich wollte auf meiner XP (inkl. aktueller SPs und Updates) die Visual Studio
Extensions vom Windows SharePoint Services 3.0 installieren. Also
runtergeladen und Doppelklick drauf. Daraufhin habe ich eine Fehlermeldung
erhalten das man die Extensions nur installieren kann wenn die Windows
SharePoint Services 3.0 installiert sind. Nun gut, kling ja auch logisch,
also hab ich mir die auch noch heruntergeladen und auch dort einen
Doppelklick drauf gemacht.

Und zur Verwunderung (nun gut einige wird es nicht verwundern) zeigt mir das
Setup eine Meldung das ich die Windows SharePoint Services 3.0 nur auf einem
Windows Server 2003 inkl. SP1 installieren kann.

Hallo?

Kann ich die Extensions nur auf einem Windows Server 2003 installieren, und
SharePoint WebParts installieren, oder gibt es eine Möglichkeit SharePoint
WebParts auch auf XP zu entwickeln? Denn meiner Meinung nach haben die
wenigsten Entwickler einen Server als Entwicklungsumgebung, sondern alle nur
eine kleine XP oder vielleicht auch Vista Maschine.

Danke für Eure Hilfe

Mirco
 

Lesen sie die antworten

#1 Fabian Moritz [MVP]
03/10/2007 - 12:40 | Warnen spam
Hallo Mirco,

ja, die Extensions musst du direkt auf den SharePoint Server installieren.
Die Entwicklung von SharePoint Komponenten (Webparts, Felder, Event Handler
usw.) verlangt, den Zugriff auf das SharePoint Objektmodell und dazu musst
du SharePoint installiert haben. Zur Entwicklung und Debugging würde ich dir
sowieso empfehlen (z.B. in einer virtuellen Maschine), direkt auf einem
Server zu arbeiten.

Viele Grüße
Fabian
Microsoft MVP - Office SharePoint Server

http://weblogs.mysharepoint.de/fabianm
http://www.sharepointcommunity.de
"Mirco Kaffsach" wrote in message
news:e8oi8H5%
Hallo zusammen,

ich habe da ein Problem, oder einfach nur ein Brett vorm Kopf.

Ich wollte auf meiner XP (inkl. aktueller SPs und Updates) die Visual
Studio Extensions vom Windows SharePoint Services 3.0 installieren. Also
runtergeladen und Doppelklick drauf. Daraufhin habe ich eine Fehlermeldung
erhalten das man die Extensions nur installieren kann wenn die Windows
SharePoint Services 3.0 installiert sind. Nun gut, kling ja auch logisch,
also hab ich mir die auch noch heruntergeladen und auch dort einen
Doppelklick drauf gemacht.

Und zur Verwunderung (nun gut einige wird es nicht verwundern) zeigt mir
das Setup eine Meldung das ich die Windows SharePoint Services 3.0 nur auf
einem Windows Server 2003 inkl. SP1 installieren kann.

Hallo?

Kann ich die Extensions nur auf einem Windows Server 2003 installieren,
und SharePoint WebParts installieren, oder gibt es eine Möglichkeit
SharePoint WebParts auch auf XP zu entwickeln? Denn meiner Meinung nach
haben die wenigsten Entwickler einen Server als Entwicklungsumgebung,
sondern alle nur eine kleine XP oder vielleicht auch Vista Maschine.

Danke für Eure Hilfe

Mirco

Ähnliche fragen