W2K8 TS NLB - Verbindungsprobleme

17/04/2009 - 20:38 von Andreas Altermann | Report spam
Hallo NG,

wir haben folgende Konstellation u.A.:

2xW2k8_32bit Terminalserver als VM im NLB-Cluster.
1xW2K8_x64 DC, der TS-Sessionbroker und TS-Gatewayserver ist.
NPS ist noch nicht aktivert. Publishing via ISA folgt noch.

Client XPSp3, VistaSp1 und VistaSp2RC
Alle Systeme sind gepatcht und haben jeweils die letzte RDP-Version je BS drauf.

Problem:
Neben der doppelten Authentifizierung (1x TGW und 1 x TS selbst),denn ein SSO gibt es
wohl noch nicht, muß der User jedes mal die RDP-Session 2-3 mal starten bis die Verbindung
endgültig steht. Ein spàterer Autoreconnect funktioniert dann ohne Probleme. Auch das Loadbalancing
funktioniert, wenn die User es geschafft haben sich anzumelden, ohne Probleme. (Kein DNS_RR)
Das Problem besteht sowohl per Netbios oder FQDN RDP_Request.

Konfiguration
TS1 mit IP x.x.x.11 (1) und x.x.x.100 (2)
TS2 mit IP x.x.x.12 (1) und x.x.x.100 (2)
x.x.x.100 = ClusterIP und hat einen Host(A) DNS_Record
NLB nur auf TCP_3389, Unicast, Keine Affinitàt,
Cluster_FQDN gem. x.x.x.100 mit A-Record

DC mit TGW und TSB
TS_Cap für AD_Gruppe "TS_User"
TS_Rap für AD_Gruppe "TS_User" und Domain (lokaler) Gruppe (da DC) "TSFARM.Domain.local" (=IP 100)
mit FQDN, Netbios und IPs der TS'ler.

Die TS'Ler sind auch Mitglied in Sessionbroker-Gruppe usw.

Wieso klappt die Verbindung nur nach dem 2.ten oder 3.ten Anmeldeversuch ?
Was haben wir evtl vergessen. (Technet-Libary 2x rauf und runter gelesen)

Hat der TGW Probleme mit dem NLB-Cluster der im VM_Bus mit den Integr.Services von Hyper-V làuft ?

Vorab vielen Dank für Euren Input, denn bald soll das System mit 4 weiteren TS im Cluster
produktiv gehen.

Gruß
Andreas Altermann
 

Lesen sie die antworten

#1 Udo Gruner
20/04/2009 - 14:11 | Warnen spam
Hallo Andreas,

"Andreas Altermann" schrieb im Newsbeitrag
news:
Hallo NG,

wir haben folgende Konstellation u.A.:

Die TS'Ler sind auch Mitglied in Sessionbroker-Gruppe usw.

Wieso klappt die Verbindung nur nach dem 2.ten oder 3.ten Anmeldeversuch ?
Was haben wir evtl vergessen. (Technet-Libary 2x rauf und runter gelesen)



Dies ist eher untypisch. Kannst Du das ganze mal nur mit dem TSG
ausprobieren und lass erstmal das NLB weg!

Hat der TGW Probleme mit dem NLB-Cluster der im VM_Bus mit den
Integr.Services von Hyper-V làuft ?



Nö eigentlich nicht!


Viele Grüße

Udo


http://udogruner.spaces.live.com

Ähnliche fragen