[W7] robocopy und Zielordner

04/05/2012 - 09:27 von Arno Welzel | Report spam
Seit kurzem nutze ich auch privat Windows 7 64-Bit. Bislang habe ich für
Datensicherungen auch unter Windows XP robocopy verwendet - allerdings
nicht die komplette Datenpartition von Windows, sondern nur einzelne
Verzeichnisse darin, weil nicht alles gesichert sein musste.

Nun habe ich größere Sicherungsmedien (vorher RDX mit 160 GB, jetzt RDX
mit 500 GB) beschafft und das entsprechende Script umgestellt, dass es
einfach die komplette Datenpartition kopiert:

if not exist f:\work mkdir f:\work
robocopy d:\ f:\work /MIR /R:0 /XD "d:\System Volume Information"

Ein Effekt, der dabei aber auftritt: Das Zielverzeichnis (f:\work) wird
von robocopy mit den Attributen hidden und system versehen - und ich
habe auch keine Möglichkeit gefunden, das abzustellen, deshalb erfolgt
danach noch ein

attrib -h -s f:\work

damit das Verzeichnis auf dem Sicherungsmedium auch sichtbar ist.

Eine Recherche bei Google ergab auch nur, dass es halt so ist. Kennt
jemand dieses Verhalten? Kann man das eleganter lösen, als
nachtràglichem zurücksetzen der Attribute?


Arno Welzel
http://arnowelzel.de
http://de-rec-fahrrad.de
 

Lesen sie die antworten

#1 Hans-Peter Matthess
04/05/2012 - 11:56 | Warnen spam
Arno Welzel:

if not exist f:\work mkdir f:\work



Warum das? Wird doch automatisch erstellt.

robocopy d:\ f:\work /MIR /R:0 /XD "d:\System Volume Information"
Ein Effekt, der dabei aber auftritt: Das Zielverzeichnis (f:\work) wird
von robocopy mit den Attributen hidden und system versehen - und ich
habe auch keine Möglichkeit gefunden, das abzustellen, deshalb erfolgt
danach noch ein
attrib -h -s f:\work



Man könnte dem Ordner ein Verbot "Attribute schreiben" verpassen.
Ansonsten: Ist auch irgendwie ungeschickt, das gesamte Laufwerk kopieren zu
wollen. Warum nicht einen Ordner "Daten" auf diesem Laufwerk und dann diesen
komplett kopieren? Wenn es aber unbedingt ein Laufwerk sein muss, könnte man
"Daten" auch mit subst zu einem Laufwerk X: machen.
Damit tritt dann dieses Problem nicht auf.

Scheinsicherheit und System-Zerstörung durch Virenscanner:
http://www.soehnitz.de/itsicherheit...index.html
Darum: http://www.soehnitz.de/itsicherheit...index.html
Konfiguration einfach gemacht: http://home.arcor.de/skanthak/safer.html

Ähnliche fragen