[w7] USB revival

25/11/2010 - 22:25 von Franz Boschl | Report spam
Hi, habe externe ports zum reinstecken für usb 2.0 und 3.0.

Gehe ich in den "Energiesparmodus" - also RAM-gespeichert - findet W7
die beiden externen USB-Platten nicht mehr.

Gehe ich in Hybernation, ist es mal so, mal so. Ich habe schon
versucht, die Variablen so zu veràndern, dass ich deutlich vor dem
"wake from hybernation" den Strom an die externen Platten schicke, die
dann auch ihre Initialisierung laut klickernd bekannt geben.

Dann aber: keine Anzeige der USB-Laufwerke. Erst ein brutaler Ripp-Off
der USB-Stecker an der Steckkarte bzw. am Gehàuse re-initialisiert die
USB-Laufwerke. I.d.R. werden Sie dann wieder erkannt und eingebunden.

Gibt es die Möglichkeit, BS-seitig die USB-Hubs bzw. Ports zum
Anmelden zu bewegen, ohne HW-màßig die Verbindung zu jancken?

Ich hatte schon an net stop net restart oder sowas gedacht.

HW: 2 usb 3.0 Steckports an einem usb 3.0 hub; entfernde ich die
externe power supply, zieht das Ding immer noch genug Strom, um die
beiden (1,5TB) Platten zu erkennen. Erst wenn ich am NEC USB-3.0 Port
ein- und ausstecke, reinitiasisiert das Ganze und die Laufwerde werden
wieder in Windows eingebunden und sind accessible. Gelegentlich sind
die Laufwerde sichtbar, melden sich aber mit 0byte und wollen
formatiert werden.

Hat jemand àhnliches? Sic: war auch schon mit USB 2.0-Stations so, ist
also kein USB-3.0 Problem.

Danke für eure Unterstützung,

Franzl
 

Lesen sie die antworten

#1 Rüdiger Rösler
26/11/2010 - 06:51 | Warnen spam
Franz Boschl typed:

Hi, habe externe ports zum reinstecken für usb 2.0 und 3.0.

Gehe ich in den "Energiesparmodus" - also RAM-gespeichert - findet W7
die beiden externen USB-Platten nicht mehr.

Gehe ich in Hybernation, ist es mal so, mal so. Ich habe schon
versucht, die Variablen so zu veràndern, dass ich deutlich vor dem
"wake from hybernation" den Strom an die externen Platten schicke, die
dann auch ihre Initialisierung laut klickernd bekannt geben.

Dann aber: keine Anzeige der USB-Laufwerke. Erst ein brutaler Ripp-Off
der USB-Stecker an der Steckkarte bzw. am Gehàuse re-initialisiert die
USB-Laufwerke. I.d.R. werden Sie dann wieder erkannt und eingebunden.

Gibt es die Möglichkeit, BS-seitig die USB-Hubs bzw. Ports zum
Anmelden zu bewegen, ohne HW-màßig die Verbindung zu jancken?

Ich hatte schon an net stop net restart oder sowas gedacht.



Das geht vielleicht mit "devcon restart <Hardware ID>". Dazu musst Du
mit dem Befehl
devcon hwids USB\*
oder
devcon hwids *
die ID Deiner USB-Laufwerke herausfinden. Man kann auch ein Skript
schreiben, dass das jedesmal automatisch beim Aufwecken erledigt.

http://groups.google.com/group/de.c...72d657a356

Ich vermute aber, dass die Treiber für die Laufwerke kaputt sind. Solche
Hardware sollte man besser nicht an einem gesunden System betreiben.
Eventuell könnte auch eine Aufgabe in der Aufgabenverwaltung erstellt
werden, die dies beim Aufwachen erledigt. Ich weiß allerdings im
Augenblick nicht, ob devcon unter Win7 funktioniert, im Lieferumfang ist
es jedenfalls nicht enthalten.

ЯR

Ähnliche fragen