W8.1: Geplante Task startet immer noch nicht :-(

22/02/2015 - 22:46 von Tilmann Reh | Report spam
Guten Abend,

ich hatte vor einiger Zeit in <m13i02$rd5$1@dont-email.me> schonmal
beschrieben: Bei meinem Laptop unter Windows 8.1 (Core) kriege ich es
einfach nicht hin, daß ein Programm mit Admin-Rechten automatisch bei
jeder Benutzeranmeldung ausgeführt wird.

Nachdem das mit QuietHDD nicht funktionierte, habe ich in der
Zwischenzeit selbst ein winziges Progràmmchen (ein paar Zeilen in
Delphi) geschrieben, das nur die APM-Einstellung der Festplatte
abschaltet. Dieses Programm funktioniert auch einwandfrei, wenn ich es
manuell "als Administrator" ausführe. (Ohne die Admin-Rechte ist der
direkte Zugriff auf die Festplatte mittels DeviceIoControl /
ATA_PASS_THROUGH nicht erlaubt.)

Aber genau wie auch schon QuietHDD làßt sich dieses Programm nicht
korrekt über die Aufgabenplanung starten. :-(
Ich habe eine Aufgabe angelegt, die jeweils 30 Sekunden nach dem
Anmelden eines beliebigen Benutzers das Programm ausführen soll, und
zwar unter dem Administrator-Konto (mit entsprechenden Zugangsdaten) -
zum Test habe ich es auch schon unter SYSTEM sowie unter einem
Benutzerkonto mit Admin-Rechten probiert.

Aber in allen Fàllen ist das Ergebnis immer das gleiche: Offenbar löst
die Aufgabenplanung tatsàchlich den Start des Programmes aus (man sieht
einen laufenden Prozess im Task-Manager), aber trotzdem macht das
Programm *nichts*. Vorher bei meinen Versuchen, QuietHDD automatisch zu
starten, hàtte es ja noch sein können, daß dieses Programm auf
irgendetwas wartet. Aber bei meinem minimalistischen "DisableAPM"
Progràmmchen kann ich das wohl ausschließen. Ich habe zum Test sogar
Konsolenausgaben eingebaut - aber keine davon wird angezeigt. Irgendwie
hàngt dieser durch die Aufgabenplanung gestartete Prozeß anschließend
komplett in der Luft, ohne irgend etwas zu tun - wàhrend beide Programme
manuell gestartet absolut korrekt laufen.

Programme, die keine Admin-Rechte benötigen, lassen sich übrigens über
die Aufgabenplanung auch nicht starten, der Effekt ist exakt derselbe:
ein toter Prozeß im Tast-Manager.

Ich wiederhole daher nochmal meine Frage von damals: wie kann man ein
Programm, das Admin-Rechte benötigt, zuverlàssig bei jeder
Benutzer-Anmeldung automatisch ausführen (lassen)? Eigentlich würde
dafür ja schon AutoStart reichen, wàren da nicht die nötigen
Admin-Rechte... :-\

Und woran könnte es liegen, daß ein (jedes?) von der Aufgabenplanung
gestarteter Prozeß anschließend ohne jede Aktivitàt vor sich hin
gammelt? Das kann doch so auch nicht im Sinne der Erfinder sein...

Danke für Tips/Hinweise
und gute Nacht,
Tilmann
 

Lesen sie die antworten

#1 Thomas Niering
23/02/2015 - 05:38 | Warnen spam
Hallo Tilmann,

Tilmann Reh wrote:
Ich habe zum Test sogar Konsolenausgaben eingebaut - aber keine davon
wird angezeigt.



Setz mal eine Batchdatei dafür ein, und lass diese in eine Datei
protokollieren...

Konsolenausgaben auf eine nicht sichtbare Konsole ist irgendwie sinnlos...

Ciao Thomas

Ähnliche fragen