Webcam-Bild kaputt - gstreamer-Problem?

27/09/2009 - 00:01 von Edzard Egberts | Report spam
Hallo,

meine Webcam lief richtig schön, mit einem astreinen, klaren Bild, bis
ich im Programm "Cheese" die Effekte ausprobiert habe, bzw. die
Programme xcam und xsane wieder entfernt habe (die genaue Ursache kenne
ich nicht, habe aber immer den Paketmanager verwendet).

Nach dem Start zeigen nun alle Webcam-Programme (habe mehrere
ausprobiert) ein total verrauschtes und "buntes" Bild, wenn ich aber in
Cheese einen Effekt dazu schalte, z.B. "Sàttigung", erhalte ich ein
ziemlich gutes Bild.

Da muss also an der unterliegenden Ebene etwas vermurkst worden sein,
was der "gstreamer" sein müsste.

Ich habe auch schon den Befehl "gstreamer-properties" gefunden und die
Plugins getestet - nach dem Umschalten zwischen Video v4l (das gar kein
Bild bringt) und v4l2 hatte ich kurzzeitig wieder das korrekte Bild, das
erschien beim Aufruf von Cheese aber nicht mehr und war danach auch
nicht reproduzierbar. Beim Aufruf werden in der Konsole auch einige
Probleme angezeigt und beim Test làuft der Fehler "Error decompressing
JPEG" durch

[ed@entwicklung /]$ gstreamer-properties
gstreamer-properties-Message: Skipping unavailable plugin 'artsdsink'
gstreamer-properties-Message: Skipping unavailable plugin 'esdsink'
gstreamer-properties-Message: Skipping unavailable plugin 'glimagesink'
gstreamer-properties-Message: Skipping unavailable plugin 'v4lmjpegsrc'
gstreamer-properties-Message: Skipping unavailable plugin 'qcamsrc'
gstreamer-properties-Message: Skipping unavailable plugin 'esdmon'
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 2 more bits
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 8 more bits
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 1 more bits
libv4lconvert: Error decompressing JPEG: fill_nbits error: need 1 more bits

Da scheint direkt beim "Video for Linux 2" v4l2 etwas nicht zu stimmen.
Was ist denn da nur passiert und wie biege ich das wieder hin? Bin
ziemlich frustriert - hatte mich gefreut, dass die Webcam so schön
funktioniert und dann war plötzlich alles im Eimer... ;o(

BTW, ist es eigentlich möglich, ein einmal erkanntes Geràt
abzuspeichern, oder muss ich meinen Scanner immer einschalten, bevor
Linux bootet? Hinterher wird der nicht mehr erkannt...
 

Lesen sie die antworten

#1 Edzard Egberts
27/09/2009 - 18:20 | Warnen spam
Am 27.09.2009 00:01, schrieb Edzard Egberts:
Da muss also an der unterliegenden Ebene etwas vermurkst worden sein,
was der "gstreamer" sein müsste.



Sieh' an, da meckert das System jetzt schon selber, weil bei der
Aktualisierung etwas schief gegangen ist:

Die "Portable library for SSA/ASS subtitles rendering :
libass-0.9.7-1.fc11 (i586)" wollte sich aktualisieren und dabei ist ein
Fehler aufgetreten:

"Fehlende Abhàngigkeit: libass.so.3 wird benötigt von Paket
gstreamer-plugins-bad-0.10.13-6.fc11.i586 : Erfolg - Leere Transaktion"

Das sieht so aus, als würde es zu meinem Webcam-Problem passen!

Laut Paketmanager sind installiert:

Portable library for SSA/ASS subtitles rendering : libass-0.9.6-2.fc11
(i586)

und

GStreamer streaming media framework "bad" plug-ins :
gstreamer-plugins-bad-0.10.13-6.fc11 (i586)

Wie behebe ich dieses Problem, das kann doch nicht so schwer sein?

Ähnliche fragen