Webservice Erreichbarkeit

02/07/2008 - 19:00 von Rainer Lemke | Report spam
Hallo NG,

Wir haben bei uns im Intranet einen NET 2.0 Webservice
laufen (auf einem WinXP prof mit IIS). Darauf greifen im
Intranet Domànenuser zu.
Wir haben eine Software die Daten über den Webservice
synchronisiert (wurde nicht von mir programmiert).
Wenn ich nun mit meinen Firmenlaptop mich von Zuhause aus
über OpenVPN mit dem Firmennetzwerk verbinde, kann sich die
Software ohne Probleme mit dem Webservice verbinden.
Nun müssen aber in Zukunft auch andere user den webservice
nutzen und dies teste ich gerade.
Dafür habe ich mich mit meinem Privat-PC über OpenVPN mit
dem Firmennetzwerk verbunden.
Das kann ich auch wenn der Privat-PC user ein völlig
unbekannter user ist solange er die verschlüsselten OpenVPN
Zugangsdaten hat, ich kann auf Ressourcen in der Firma
zugreifen.
Allerdings kann die Software den Webservice nicht
ansprechen, es kommt nur die Meldung von der Software
"...the webservice could not be found at the specified
address..." Der webservice wird wohl über einen eigens
eingerichteten user angesprochen, in der IIS webseite ist
dieser user eingerichtet.
Der Webservice wird über die IP Adresse angesprochen.
Wenn ich den webservice Aufruf im IE eingebe werden mir auch
die webservice Methoden aufgelistet.
Ich habe dann auf meinem lokalen PC den gleichen user mit
gleichem passwort wie in der Firma eingerichtet aber da
findet er den werbservice auch nicht. Auf dem lokalen PC
habe ich für den Test alle Firewalls abgeschaltet und hinter
dem VPN liegt keine Firewall.

Habt ihr eine Idee warum ich keinen Connect zum webservice
bekomme?


Einen schönen Gruss aus dem Rheinland,
Rainer Lemke
 

Lesen sie die antworten

#1 Stefan Falz [MVP]
02/07/2008 - 19:13 | Warnen spam
Hallo Rainer,

"Rainer Lemke" schrieb:

Allerdings kann die Software den Webservice nicht
ansprechen, es kommt nur die Meldung von der Software
"...the webservice could not be found at the specified
address..." Der webservice wird wohl über einen eigens
eingerichteten user angesprochen, in der IIS webseite ist
dieser user eingerichtet.



Der IIS dürfte (wenn die Meldung, dass der Webservice nicht
gefunden wird, stimmt) nichts damit zu tun haben.

Ich habe dann auf meinem lokalen PC den gleichen user mit
gleichem passwort wie in der Firma eingerichtet aber da
findet er den werbservice auch nicht.



D.h., wenn Du dich auf deinem lokalen PC (der nicht in einer
Domàne ist?) anmeldest, IE startest und den Webservice aufrufst,
klappt es? Wenn Du dich jetzt lokal als der "andere" Benutzer
anmeldest, IE startest und den Webservice aufrufst, klappt es
nicht? Falls ja, könnte ich mir höchstens einen Proxyserver o.à.
(ISA Server) vorstellen, der benutzerbezogen arbeitet. Wenn
die Software selbst immer mit einem bestimmten Benutzerkonto
arbeitet könnte es auch den lokalen Proxyeinstellungen liegen.

Falls das Problem immer nur mit der Fremdsoftware auftritt, wird
die wohl keinen Connect über euer VPN hinbekommen. In dem Fall
musst Du dich aber eher an den Hersteller der Software wenden.

Tschau, Stefan
Microsoft MVP - Visual Developer ASP/ASP.NET
http://www.asp-solutions.de/ - Consulting, Development
http://www.aspnetzone.de/ - ASP.NET Zone, die ASP.NET Community

Ähnliche fragen