Webservice: Parserfehlermeldung

25/08/2007 - 08:40 von Oskar Vaia | Report spam
Hallo,

ich habe mit VS 2005 einen Webservice erstellt und dann ein WebSetup-Projekt
hinzugefügt. Die daraus resultierende Datei habe ich dann auf einem Win 2003
R2-Server, wo auch der IIS drauf làuft, installiert.
Versuche ich den Webservice auf dem Server im IE 7.0 aufzurufen, erhalte ich
folgende Fehlermeldung:

Serverfehler in der Anwendung /WebSetupTest.

Parserfehler
Beschreibung: Fehler beim Verarbeiten einer Resource, die für diese
Anforderung erforderlich ist. Überprüfen Sie folgende Fehlerinformationen
und àndern Sie die Quelldatei entsprechend.

Parserfehlermeldung: Der Typ WebServiceTest.Service1 konnte nicht erstellt
werden.

Quellfehler:


Zeile 1: <%@ WebService Language="VB" CodeBehind="Service1.asmx.vb"
Class="WebServiceTest.Service1" %>



Quelldatei: /websetuptest/service1.asmx Zeile: 1


Versionsinformationen: Microsoft .NET Framework-Version:2.0.50727.42;
ASP.NET-Version:2.0.50727.210

Kann mir da bitte jemand weiterhelfen, was da wohl falsch konfiguriert ist?
Auf meiner Entwicklungsmaschine (Win Vista) làuft der Webservice ohne
Probleme.

Dank und Grüße

Oskar
 

Lesen sie die antworten

#1 Stefan Falz [MVP]
25/08/2007 - 11:30 | Warnen spam
Hallo Oskar,

"Oskar Vaia" schrieb:

Parserfehlermeldung: Der Typ WebServiceTest.Service1 konnte nicht erstellt werden.



Ist das Anwendungsverzeichsnis im IIS als eigene Applikation eingerichtet?

IIS MMC
-> Website
-> Verzeichnis
-> Eigenschaften
-> Reiter "Verzeichnis"
-> Button "Erstellen"

(kann geringfügig anders aussehen, hab grad nur Vista hier)

Tschau, Stefan
Microsoft MVP - Visual Developer ASP/ASP.NET
http://www.asp-solutions.de/ - Consulting, Development
http://www.aspnetzone.de/ - ASP.NET Zone, die ASP.NET Community

Ähnliche fragen