Welche Java-Laufzeitumgebung?

04/09/2010 - 11:35 von Pit Zyclade | Report spam
Vorweg: Ich bin ein DAU!
In den Diskussionen um Postgres-DBMS fiel mir auf, daß man für OOo auch eine
JRE-Datei benötigt. Zumeist holt sich der Win-User aber das komplette Paket mit
JRE und alles làuft nach der Installation.

Wenn ich mir die vorhandenen Java Optionen unter Optionen->OOorg->Java
auflisten lasse, finde ich Versionen 1.5.0.04, 1.6.0_03, 1.6.0.05, 1.6.0.07 und
1.6.0._21. Der Punkt liegt bei 1.6.0._07

Nun kommen mir Fragen auf:
- Gibt diese Anzeige an, welche JRE man wàhlen könnte
oder welche Versionen im System vorhanden sind?
- Wàre denn die Version 1.6.0_21 (höher vermutlich, also neuer) nicht besser?

Kann und soll man die JRE selbst updaten oder nicht?

Danke für Antwort

Pit Zyclade
 

Lesen sie die antworten

#1 Volker Kohaupt
04/09/2010 - 12:49 | Warnen spam
Pit Zyclade <PitZyclade schrieb:

Wenn ich mir die vorhandenen Java Optionen unter Optionen->OOorg->Java
auflisten lasse, finde ich Versionen 1.5.0.04, 1.6.0_03, 1.6.0.05,
1.6.0.07 und 1.6.0._21. Der Punkt liegt bei 1.6.0._07

Nun kommen mir Fragen auf:
- Gibt diese Anzeige an, welche JRE man wàhlen könnte
oder welche Versionen im System vorhanden sind?



Beides. Bei dir im System sind mehrere JRE installiert und aus diesen
kannst du dir in OpenOffice eine auswàhlen.


- Wàre denn die Version 1.6.0_21 (höher vermutlich, also neuer) nicht
besser?



Jain, wie mit allen neuen Versionen eines Softwarepakets kann aber muß
dieses nicht besser sein. In einer neueren Version sind in der Regel
Bugs beseitigt worden was aber auch dazu führen kann das sich dadurch
oder durch Erweiterung des Softwarepakete neu einschleichen.

Wenn du mit der jetzigen eingestellten Version Problemlos arbeiten
kannst, vermerkst du dir das in deinen Unterlagen damit du nach Bedarf
wieder auf diese zurückgreifen kannst. Jetzt würde ich vorschlagen auf
die nàchst höheren Version um zu schalten und deine Applikation testen,
ob alles rund und sauber und nach deinen Wünschen làuft.

Zum Beispiel habe ich hier im Haus unter der OpenSuse 11.3 folgendes
Problem. Siehe 2. Abschnitt
http://linuxecke.volkoh.de/opensuse...se113.html


Kann und soll man die JRE selbst updaten oder nicht?



Kann, ja.
Soll, ja wenn die Notwendigkeit besteht.

Viele grüße von Volker und dem Pinguin
http://linuxecke.volkoh.de/

Ähnliche fragen