Welche Library für GIF?

17/08/2008 - 15:06 von Paul Lenz | Report spam
Ich versuche gerade, ein Programm in Perl zu schreiben,
das GIF-Bilder einlesen und weiterverarbeiten soll. Dazu
will ich das Modul "Imager" benutzen. Dieses streikt
leider beim Einlesen eines Bildes:
"Cannot read: format 'gif' not supported ..."

In der Docu steht ein knapper Hinweis:
"... assuming you have the appropriate libraries..."

Auf der Suche nach Libraries habe ich alles mögliche
ausprobiert:

apt-get install libungif4g
apt-get install libungif-bin
apt-get install libgd1g


das hat aber den Fehler nicht behoben, und diverse andere
Versuche endeten mit

Couldn't find package libgif (oder àhnlich)



Welches Library möchte Imager installiert bekommen?


Paul Lenz
 

Lesen sie die antworten

#1 Michael Andresen
17/08/2008 - 16:59 | Warnen spam
On 2008-08-17, Paul Lenz wrote:
Ich versuche gerade, ein Programm in Perl zu schreiben,
das GIF-Bilder einlesen und weiterverarbeiten soll. Dazu
will ich das Modul "Imager" benutzen. Dieses streikt
leider beim Einlesen eines Bildes:
"Cannot read: format 'gif' not supported ..."

In der Docu steht ein knapper Hinweis:
"... assuming you have the appropriate libraries..."

Auf der Suche nach Libraries habe ich alles mögliche
ausprobiert:
apt-get install libungif4g
apt-get install libungif-bin
apt-get install libgd1g





Debians Seite sagt:
libgif4 (>= 4.1.6)
library for GIF images (library)
http://packages.debian.org/sv/sid/libimager-perl

Da kann man auch einem link zur Seite ueber die libgif4 folgen:
http://packages.debian.org/sv/sid/libgif4
Hilft das?

//M

Ähnliche fragen