WENN Abfrage liefert falschen Wert mit HEUTE(), wenn das betreffende Feld leer ist

27/03/2011 - 19:56 von Michael Muccicer | Report spam
ich schreibe an einem wenn Vergleich, wenn die Betreffenden Felder mit einem
Datum versehen sind funktiniert es, doch wenn ein Feld leer ist, dann gibt
es mir auch meine AUSGABE (FEHLER) aus, obwohl eigentlich NIX da stehen
sollte

=WENN(A1>=HEUTE();"";"FEHLER")

Michi
 

Lesen sie die antworten

#1 Díetmar Vollmeíer
27/03/2011 - 20:03 | Warnen spam
Guten Abend Michael!

*Michael Muccicer* schrieb am 27.03.2011 um 19:56 Uhr...
ich schreibe an einem wenn Vergleich, wenn die Betreffenden Felder mit einem
Datum versehen sind funktiniert es, doch wenn ein Feld leer ist, dann gibt
es mir auch meine AUSGABE (FEHLER) aus, obwohl eigentlich NIX da stehen
sollte



Eine Leere Zelle wird beim Vergleich als 0 (NULL) erkannt und somit
eigentlich richtig ausgewertet.

=WENN(A1>=HEUTE();"";"FEHLER")



Ändere für deinen Zweck die Formel in

=WENN(ODER(ISTLEER(A1);A1>=HEUTE());"";"FEHLER")

HTH
Servus | "Alles geht auf einmal schief."
Didi | --> Murphy's Gesetz

Ähnliche fragen