WENN Bedingung - unterschiedliches VErhalten in Writer und Calc

01/12/2009 - 12:21 von Jörg Pietschmann | Report spam
Hallo Allerseits,

ich nage immer noch an meiner Wenn - Dann Bedingung in einem Writer
Dokument. <4b13db19$0$6587$9b4e6d93@newsspool3.arcor-online.net>

Hierzu aber eine allgemeine Frage, daher in .misc:

Wenn ich in einem Writer-Dokument (egal ob SO5.2 oder OOo 3.1.0)
folgende Bedingung als Formel in den Fließtext eingebe (F2)

=WENN((<Tabelle1.A2>*0,1)<`0;600;<Tabelle1.A2>*0,1)

meldet das Programm: **fehlerhafter Ausdruck**
(Anm.: Tabelle1 existiert natürlich im Dokument)


Wenn ich die selbe Formel in eine Zelle einer Writer-Tabelle eingebe,
rechnet das Programm immer 10% der Zelle A2 aus, egal ob die WENN
Bedingung erfüllt ist, oder nicht - die WENN Bedingung wird also ignoriert.


Wenn ich diese Formel sinngemàß mit

=WENN((<A2>*0,1)<`0;600;<A2>*0,1)

in ein CALC Dokument eingebe, wird die WENN Bedingung beachtet und die
gewünschten Werte ausgegeben.


In der Hilfe steht dazu nur:

[Zitat Hilfe]

Berechnen komplexer Formeln in Textdokumenten

Sie können in einer Formel vordefinierte Funktionen verwenden und das
Ergebnis der Berechnung dann in ein Textdokument einfügen.
Um beispielsweise den Mittelwert dreier Zahlen zu berechnen, gehen Sie
wie folgt vor:
1.Klicken Sie im Dokument an die Stelle, an der Sie die Formel einfügen
möchten, und drücken Sie F2.
2.Klicken Sie auf das Symbol Formel und wàhlen Sie "Mittelwert" aus dem
Untermenü.
3.Geben Sie die erste Zahl gefolgt von einem vertikalen Strich (|) ein
und wiederholen Sie diesen Schritt für die beiden anderen Zahlen.
4.Drücken Sie die Eingabetaste, und Sie sehen im Text das Ergebnis. Es
ist als Feldbefehl eingefügt worden.
Um die Formel zu bearbeiten, doppelklicken Sie auf das Feld im Dokument.

[/Zitat Hilfe]


Ist es nun so, daß in Writer nur die *vordefinierten* Funktionen
verwendbar sind, die in der dropdown-Liste des Formelassistenten
gelistet sind? (Auch wenn ich gar nicht über die dropdown Liste bei (F2)
gehe, sondern die Formel als Variable über 'Einfügen' -> 'Feldbefehl' ->
'Andere...' -> 'Variablen' -> 'Formel einfügen' direkt definiere...)

Hat jemand eine Möglichkeit gefunden in Writer WENN Bedingungen zu
verwenden die funktionieren?

1000 Dank für Hinweise!

Jörg
 

Lesen sie die antworten

#1 Siegfried Höfner
01/12/2009 - 13:55 | Warnen spam
"Jörg Pietschmann" schrieb
[...]
Ist es nun so, daß in Writer nur die *vordefinierten* Funktionen verwendbar sind, die in der dropdown-Liste des Formelassistenten
gelistet sind? (Auch wenn ich gar nicht über die dropdown Liste bei (F2) gehe, sondern die Formel als Variable über 'Einfügen' ->
'Feldbefehl' -> 'Andere...' -> 'Variablen' -> 'Formel einfügen' direkt definiere...)



Das Thema hatten wir schon mal und wenn ich mich richtig entsinne, gehen
nur die Funktionen, die auch in der Liste stehen.

Gruß Siegfried

Ähnliche fragen