WENN-Formel kürzen

19/09/2007 - 19:37 von Ralf Brinkmann | Report spam
Hallo Alle!

Meine SUMMENPRODIKT-Formel in dem Jahres-Einsatzkalender liefert immer
wieder einen Fehler #WERT!, weil ich nicht bedacht habe, dass manche
Jahre 365 Tage haben, andere 366. Ich muss also abfragen, ob im letzten
Kàstchen $C$378 etwas drinsteht oder nicht und dann die Matrix
entsprechend eine Zelle lànger oder kürzer beschreiben:

=WENN($C$378<>"";SUMMENPRODUKT((MONAT($C$13:$C$378)=1)*($F$13:$P$378="MEYER"));SUMMENPRODUKT((MONAT($C$13:$C$377)=1)*($F$13:$P$377="MEYER")))

Das geht doch bestimmt auch einfacher (also ohne Wiederholung der ganzen
Formel) auszudrücken, oder?

Gruß, Ralf
 

Lesen sie die antworten

#1 Klaus \Perry\ Pago
19/09/2007 - 21:39 | Warnen spam
"Ralf Brinkmann" schrieb im
Newsbeitrag
news:
Hallo Alle!

Meine SUMMENPRODIKT-Formel in dem Jahres-Einsatzkalender liefert immer
wieder einen Fehler #WERT!, weil ich nicht bedacht habe, dass manche
Jahre 365 Tage haben, andere 366. Ich muss also abfragen, ob im letzten
Kàstchen $C$378 etwas drinsteht oder nicht und dann die Matrix
entsprechend eine Zelle lànger oder kürzer beschreiben:

=WENN($C$378<>"";SUMMENPRODUKT((MONAT($C$13:$C$378)=1)*($F$13:$P$378="MEYER"));SUMMENPRODUKT((MONAT($C$13:$C$377)=1)*($F$13:$P$377="MEYER")))

Das geht doch bestimmt auch einfacher (also ohne Wiederholung der ganzen
Formel) auszudrücken, oder?




Hallo Ralf,

es müsste reichen, .. $C$13:$C$378<>"" .. einzubauen.

=SUMMENPRODUKT(($C$13:$C$378<>"")*(MONAT($C$13:$C$378)=1)*($F$13:$P$378="MEYER"))

Gruß
Klaus

Ähnliche fragen