wenn Funktion

22/04/2012 - 09:57 von Jürgen Großmann | Report spam
Hallo
Ich habe folgenden Tabellenaufbau
In Spalte A4 nis A34 steht der Wochentag mit der Formel
=WENN(B25="";"";TEXT(WOCHENTAG(B25);"TTT"))
In der Spalte B4 bis B34 steht das Datum. von B2 bis B32 steht folgende
Formel
=WENN(B29="";"";B29+1)
in B33 habe ich folgendes stehen
=WENN(TAG(DATUM(JAHR(B31);MONAT(B31)+1;0))>28;B31+1;"")

wenn nich nun in Zelle B4 das ein Datum eintrage werden die
nachfolgenden Zellen automatisch ausgefüllt. Das Problem liegt darin das
bekanntlichger weise nicht alle Monate 31 Tage haben und ab und zu der
Februar auch 29 Tage hat. Es soll aber nur die Tage aufgelistet werden
die ein Monat auch nur hat. Wie bekomme ich das hin.
Gruß Jürgen
 

Lesen sie die antworten

#1 Claus Busch
22/04/2012 - 10:35 | Warnen spam
Hallo Jürgen,

Am Sun, 22 Apr 2012 09:57:44 +0200 schrieb Jürgen Großmann:

In Spalte A4 nis A34 steht der Wochentag mit der Formel
=WENN(B25="";"";TEXT(WOCHENTAG(B25);"TTT"))



du musst nicht mit Wochentag arbeiten. Es reicht, wenn du
=WENN(B4="";"";TEXT(B4;"TTT"))
nimmst. Außerdem müsstest du bei WOCHENTAG als zweites Argument die 2
nehmen für das deutsch System, indem die Woche mit Montag anfàngt, also
WOCHENTAG(B25;2)
Ohne das zweite Argument ist es das US-System, in dem die Woche mit
Sonntag beginnt.

In der Spalte B4 bis B34 steht das Datum. von B2 bis B32 steht folgende
Formel
=WENN(B29="";"";B29+1)
in B33 habe ich folgendes stehen
=WENN(TAG(DATUM(JAHR(B31);MONAT(B31)+1;0))>28;B31+1;"")



ohne VBA wirst du am Ende Fehlerwerte bekommen. Aber probiers mal so:
=WENN(MONAT(B4+1)>MONAT($B$4);"";B4+1)


Mit freundlichen Grüßen
Claus Busch
Win XP Prof SP3 / Vista Ultimate SP2
Office 2003 SP3 /2007 Ultimate SP3

Ähnliche fragen