Wenn Funktion und Datum

04/02/2008 - 11:10 von jochen | Report spam
Hallo, NG,

ich will eine Wenn-Funktion mit einem Datum anlegen. Das heißt ich
habe eine Spalte mit den verschiedensten Datums-Werten (z.B.
28.10.2007) und will in der Funktion sagen, dass wenn das Datum
kleiner als der 31.10.2007 ist, er den Wert, der in der Spalte daneben
steht nehmen soll, ansonsten 0.
Daneben habe ich noch eine Wenn-Funktion, die besagt, dass wenn das
Datum größer als der 01.11.2007 ist, der Wert, der in der Spalte
daneben steht, genommen wird, ansonsten 0.

So, und jetzt habe ich das Problem, das das Programm zum Teil die
richtigen Ergebnisse liefert, zum Teil falsche und zum Teil tràgt es
in beiden Formeln die selben Werte ein.

Ich denke, ich mache irgendwas mit der Datumsformat falsch.

Wer kann mir helfen?

Danke im voraus
 

Lesen sie die antworten

#1 Peter Schleif
04/02/2008 - 11:18 | Warnen spam
jochen schrieb:

Ich denke, ich mache irgendwas mit der Datumsformat falsch.



Das wàre einfacher zu beurteilen, wenn Du deine Formeln angegeben
hàttest. Sehen sie vielleicht etwa so aus?

=WENN(A1<"31.10.2007";D1;0)

Das kann nicht klappen, weil "31.10.2007" ein String ist. Du musst
aber mit einem Datums-Wert vergleichen. Zum Beispiel so:

=WENN(A1<DATWERT("31.10.2007");D1;0)

Peter

Ähnliche fragen