Wenn

31/12/2008 - 12:54 von Werner Studer | Report spam
Hallo zusammen
Mit einer Wenn Formulierung habe ich Probleme, im Hilfe Menu steht
folgendes:
Um kompliziertere Bedingungen zu formulieren, können bis zu 64
WENN-Funktionen als Argument Dann_Wert und Argument Sonst_Wert verschachtelt
werden.

Bei der Formel

=Wenn(V15=0;"";Wenn(T24>99;A5;Wenn(H7>0;A7;Wenn(H8>0;A8;Wenn(H9>0;A9;Wenn(H10>0;A10;Wenn(H11>0;A11;Wenn(H12>0;A12;))))))))

Nach einer weiteren Wenn Formel integration gekomme ich folgende Melden:

Die angegebene Fromel kann nciht eingegeben werden, da sie mehr
Verschachtelungsebenen verwendet, als im aktuellen Dateiformat zulàsslig
sind.

Was muss ich machen, damit ich weitere Wenn Abfragenmachen kann, was ist mit
dem Dateiformat gemeint. Ich werde Excel Version 2007, speichere aber die
Datei in Excel 2003.

Danke für die kooperative Unterstützung.

Guets Neus und en gute Rutsch ins 2009.

Werner
 

Lesen sie die antworten

#1 Hajo_Zi
31/12/2008 - 13:14 | Warnen spam
Hallo Werner,

Mehr als 8 Ebenen bei wenn
Eine Formel kann bis zu sieben Ebenen einer verschaltelter Funktion enthalten.
http://www.excelformeln.de/formeln.html?welcher8
=WENN(A1=1;1;WENN(A1=2;2;WENN(A1=3;3;WENN(A1=4;4;WENN(A1=5;5;WENN(A1=6;6;WENN(A1=7;7;)))))))+WENN(A1=8;8;WENN(A1=9;9;WENN(A1;10;WENN(A1;11;WENN(A1;12;)))))
von WF
Die Grenze liegt bei 1024 Zeichen für die Formel.

Wichtig ist es, die erste 7 Gruppe auf "" bei Text, dann weiter mit & oder
auf 0 bei Zahl, dann weiter mit +enden zu lassen.
Hinweis Hein Ulm

Gruß Hajo
MVP für Microsoft Excel
Betriebssystem Vista Ultimate SP1 und Excel Version2007 SP1
http://Hajo-Excel.de/



"Werner Studer" wrote:

Hallo zusammen
Mit einer Wenn Formulierung habe ich Probleme, im Hilfe Menu steht
folgendes:
Um kompliziertere Bedingungen zu formulieren, können bis zu 64
WENN-Funktionen als Argument Dann_Wert und Argument Sonst_Wert verschachtelt
werden.

Bei der Formel

=Wenn(V15=0;"";Wenn(T24>99;A5;Wenn(H7>0;A7;Wenn(H8>0;A8;Wenn(H9>0;A9;Wenn(H10>0;A10;Wenn(H11>0;A11;Wenn(H12>0;A12;))))))))

Nach einer weiteren Wenn Formel integration gekomme ich folgende Melden:

Die angegebene Fromel kann nciht eingegeben werden, da sie mehr
Verschachtelungsebenen verwendet, als im aktuellen Dateiformat zulàsslig
sind.

Was muss ich machen, damit ich weitere Wenn Abfragenmachen kann, was ist mit
dem Dateiformat gemeint. Ich werde Excel Version 2007, speichere aber die
Datei in Excel 2003.

Danke für die kooperative Unterstützung.

Guets Neus und en gute Rutsch ins 2009.

Werner



Ähnliche fragen